Ask Your Question
4

Latest kernel breaks Nvidia and won't launch

asked 2017-07-06 01:30:35 -0500

scavy gravatar image

updated 2017-07-06 23:36:56 -0500

I recently ran a Dnf Upgrade/Install and upgraded my kernel to 4.11.8-200.fc25.x86_64 and it resulted in my Nvidia drivers malfunctioning, being that my multiple displays were no longer recognized and my desktop environment (cinnamon) was forced into software rendering. NOTE that my NVIDIA installation method was through RPMFusion I ran nvidia-settings to try and fix the problem and rebooted, now the boot screen is a blank cursor after grub selection and I can't input anything or drop to a shell, F1/2/3/4 does nothing also. For now I've reverted to the previous kernel installation which still works fine but Im not sure what the problem is and I would like to fix it.

*EDIT *** Here is my lspci / dnf output:

[exas@localhost Downloads]$ lspci | grep -i Nvid

01:00.0 VGA compatible controller: NVIDIA Corporation GM206 [GeForce GTX 960] (rev a1)

01:00.1 Audio device: NVIDIA Corporation Device 0fba (rev a1)

[exas@localhost ~]$ dnf list installed | grep nvid

akmod-nvidia.x86_64 2:375.66-3.fc25 @rpmfusion-nonfree-updates

kmod-nvidia-4.10.6-200.fc25.x8664.x8664

xorg-x11-drv-nvidia.x86_64 2:375.66-7.fc25 @rpmfusion-nonfree-updates

xorg-x11-drv-nvidia-kmodsrc.x86_64 2:375.66-7.fc25 @rpmfusion-nonfree-updates

xorg-x11-drv-nvidia-libs.i686 2:375.66-7.fc25 @rpmfusion-nonfree-updates

xorg-x11-drv-nvidia-libs.x86_64 2:375.66-7.fc25 @rpmfusion-nonfree-updates

Thank you for any assistance

edit retag flag offensive close merge delete

Comments

were you running proprietary? was dkms enabled? I run nvidia 381.22 and used dkms during install, to have it setup the kernel drivers, after each kernel update. I have 6 kernels, that i keep as backup, and all six work with the driver. Update:installed 384.47 nvidia and running kernel 4.11.8-200.fc25.x86_64

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-06 07:25:34 -0500 )edit

@steveebey I checked the Nvidia website and 375.66 is the correct version for my card. Should I try to force 384.47? I already have working kernels <4.11.8-200 and would like to prevent breaking more. By the way, which method did you use to install your drivers?

scavy gravatar imagescavy ( 2017-07-06 23:05:27 -0500 )edit

i simply download the driver, then from terminal do init 3 which puts system in console mode. then run the driver install file, and when asked, enable dkms and i also install 32 bit compatibility for wine and steam and windows games. need to have some fun. after install, i reboot and all is good. no akmod, or rpmfusion, and when i enable dkms it automatically builds new drivers for each kernel upgrade that comes.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-07 07:37:55 -0500 )edit

@steveebey - is there a guide somewhere talking about the process that you are talking about? I have this issue from time to time that scavy is talking about and it sounds like I could get around by following the steps you are taking.

EDIT: spelling.

blindcant gravatar imageblindcant ( 2017-12-11 03:16:27 -0500 )edit

@steveebey I said yes to use dkms on the nvidia install and the kernel upgrade today (1st after I installed nvidia drivers last week) broke Xorg... "no screens found"

Is there a simple way to fix this and why didn't dkms work? Thanks, Bill

billwilliams gravatar imagebillwilliams ( 2018-01-04 05:50:51 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
4

answered 2017-07-06 23:35:48 -0500

scavy gravatar image

So it turns out that my kmods wasn't built when I updated. The following solved my problem:

1)Get to the blank screen 2) Alt + F2 for a shell 3) su 4) akmods --force 5) reboot

edit flag offensive delete link more

Comments

yet another kernel update, flawlessly performed with dkms and running 384.47 on my geforce gtx 970. Not sure what is wrong with akmod and kmod but they seem to run behind the kernel updates by a little bit. simpler for me to allow dkms to compile modules from source, on my system, instead of waiting on updates to the various rpm and kmod programs.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-14 07:33:02 -0500 )edit

Thanks you saved my day

kev0055 gravatar imagekev0055 ( 2017-12-27 22:34:16 -0500 )edit
1

answered 2017-12-11 13:20:39 -0500

SteveEbey73701 gravatar image

updated 2017-12-11 13:27:24 -0500

Here are the exact steps that I used, to install nvidia and eliminate nouveau.

start terminal

sudo -i
dracut --omit-drivers nouveau /boot/initramfs-$(uname -r).img $(uname -r) --force
systemctl set-default multi-user.target 
reboot

login as root

dnf install kernel-devel-$(uname -r) gcc dkms acpid
bash /dirofsavedfile/NVIDIA-Linux-x86_64-...run (driver version number in place of ..)

Accept license, say yes to DKMS and 32 bit library installation. If running in secure boot EFI, you will be possibly need to make a digital key. I do not fully understand that procedure, so I disabled secure boot in my bios and did not have to do that step.

systemctl set-default graphical.target
reboot

I have been using the nvidia proprietary dkms update through F24,F25,F26 and now F27. Since the dracut removed nouveau, I only have to do the install when nvidia releases new drivers. I am running 387.34 right now, with steam and wine as well, and enjoying some decent performance in the games I play. Also better smoother graphics in Linux on my cinnamon desktop. When I get new drivers from Nvidia, the installation is simpler, since all the dkms components are installed. The steps to install new drivers, after you download and save the run file from the nviidia website, are as follows:

start terminal
sudo init 3
cd /path/to/downloaded/driver
./NVidiadriverfileyou downloaded.run

answer yes to dkms and 32 bit. You might get a message about missing libglvnd, I select overwrite and replace in response to that message, and continue. When it completes, then just

reboot

Hope this helps, and enjoy your new drivers.

I use the link, and scroll to the bottom to find the latest drivers.

edit flag offensive delete link more

Comments

I downloaded version 390.25 through "wget --no-check-certificate NVIDIA-<version>.run", installed using your recommended procedure and it worked on Fedora 27, kernel 4.14.

Jefferson Cavalcante gravatar imageJefferson Cavalcante ( 2018-01-29 14:55:07 -0500 )edit
0

answered 2017-07-14 00:09:02 -0500

Hello!

1)Get to the blank screen 2) Alt + F2 for a shell 3) su 4) akmods --force 5) reboot

That didn't work for me since I couldn't access the virtual console.

What worked was: 1. At the boot screen, where you choose kernels, press "e". 2. From the line starting with linuxefi eliminate all references to nouveau. 3. For me, these arguments are:

nouveau.modeset=0
rd.driver.blackllist=nouveau
modprobe.blacklist=nouveau

4. Press Ctrl+X. Now you should be able to access the virtual console by pressing Ctrl+Alt+F1/F2. 5. Login with your user and type:

sudo akmods # note the fact that some modules weren't built correctly
sudo akmods --force

That should be it.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-07-06 01:30:35 -0500

Seen: 4,379 times

Last updated: Dec 11 '17