Ask Your Question
0

grub normal.mod missing, how to fix?

asked 2017-07-04 11:34:09 -0500

Enzo gravatar image

updated 2017-07-05 02:44:31 -0500

Can anyone help me with this?? I ran into this problem while changing my wireless adapter(swap), after i changed it, my pc cannot be turn on, after attempt to reinstall it and finally managed to turned on. But the big problem comes, normal.mod is not found, and i stuck at this grub rescue for hours. Tried restore UEFI/bios settings to default but didn't help. I had also tried to ls the all the hdX partition, with /boot, but still can't find it. as follows: image description

May i know what should i do now?? how to find the normal.mod or recover GRUB??

UPDATE: In grub rescue, i was not able to view contents of My SSD(lvm) which the OS is installed.

My hard disk structure:

128GB SSD (hd1)-unable to load SSD's content in grub rescue

|- -/dev/sda1

|--/dev/sda2

|--/dev/sda3

1TB HDD (hd2)~ext4

|--/dev/sdb

500GB HDD (hd0)

|--/dev/sdc1 (hd0,1)~ext4

|--/dev/sdc2

|--/dev/sdc5 (hd0,5)~ntfs,unable to view

|--/dev/sdc6 (hd0,6)~ext4

320GB HDD (hd3)

|--/dev/sdd1 (hd3,1)~ext4

|--/dev/sdd2 (hd3,2)~ntfs, unable to open

My hdd partition are as follows(loaded using live cd) image description

My main harddisk(SSD), with fedora installed(LVM) image description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-05 02:42:03 -0500

Enzo gravatar image

Managed to solve this, thanks to @ahmad-safir 's solution from This page

Since I was not able to load the SSD in GRUB SECURE which contains the /boot, so i'm just reinstall the GRUB bootloader.

1)By using a live usb, Create mount point and mount /

mkdir /mnt/sysimage

mount /dev/fedora/root /mnt/sysimage

2) Mount /boot directory

mount /dev/sda2 /mnt/sysimage/boot

3) Run the following

grub2-install --root-directory=/mnt/sysimage /dev/sda

4) Restart .... ... Grub prompt again, but seems different image description

This time, SSD partition is shown. follow answer from UnixExchange to load the kernel.

In my case,

linuxefi (hd1,gpt2)/vmlinuz-4.11.7-200.fc25.x8664 root=/dev/fedoraetpc/root

initrdefi (hd1,gpt2)/initramfs-4.11.7-200.fc25.x86_64.img

boot

Finally can launch my fedora...

But not yet, every time i restart my pc, this grub prompt appears,

I did run

grub2-mkconfig -0 /boot/efi/EFI/fedora.grub.cfg

but nothing had change.

Tried many times, can pass this grud command with just

normal

but still can't get rid of this.

One weird thing is, my SSD volume name has changed to hd0 after this..anyone know why??

At last, after few hours of struggle, i follow steps from fedoraproject and IT WORKS.

grub2-mkconfig -o /boot/grub2/grub.cfg

grub2-install --boot-directory=/boot /dev/sda

FInally , my system back to normal.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-07-04 11:30:03 -0500

Seen: 773 times

Last updated: Jul 05 '17