Ask Your Question
0

Why won't my clock maintain the correct time?

asked 2012-01-10 04:19:05 -0500

viajeramental gravatar image

updated 2012-01-12 09:56:05 -0500

FranciscoD_ gravatar image

Hello!

I'm using Fedora 16 with KDE on a netbook. I set clock to use local time (not UTC) and to synchronize over the net. Ok. Everything works only when I'm connected to internet. When I get disconnected time shown in clock jumps 2 hours in to the future. In example, if it's 18:31, it shows 20:31. I unticked "synchronize with a server" and fix manually the hour. It works well untill shutdown. When I use again my netbook, "magically" it comes back to wrong hour.

So, I never get a working clock because when I'm connected it has a right hour but when I disconnected it has 2 more hours.

Is very, very annoying. How can I fix it?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

Would you mind reformatting your question?

lzap gravatar imagelzap ( 2012-01-10 05:23:30 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-01-11 07:27:37 -0500

viajeramental gravatar image

Solved! It was a lack of app. I didn't have ntp installed. I've installed ntpd and other relationed packages and now works fine. Connected and disconnected. Thanks very much!

edit flag offensive delete link more

Comments

If this is Fedora 16 it uses different time synchronizer by default fyi. And also marking yourself as an answer does not give you any credit points ;-)

lzap gravatar imagelzap ( 2012-01-12 10:23:53 -0500 )edit
3

answered 2012-01-10 05:35:19 -0500

lzap gravatar image

I think the problem is in your BIOS UTC setting. When your laptop is connected to the internet, the time synchronizer sets the internet time. Btw time synchronizer is much "faster" now in Fedora 16 than ntpd that was used in Fedora 15 and older versions.

When you boot your laptop without internet, your BIOS time is set, which is incorrect. Possible causes:

1) Fedora is not synchronizing BIOS time on shutdown. If you did a fresh install, this should not be the case as it sync it automatically.

2) You have a Windows installed on the same box and you set BIOS to UTC. If you boot to Windows and you instructed Fedora to store time in UTC in BIOS, Windows will likely set it to local time. Those two will be "figting". To fix this run "system-config-date" in the console, provide your root password and uncheck the System clock use UTC setting on the second page.

http://docs.fedoraproject.org/en-US/Fedora/13/html/Installation_Guide/s1-timezone-x86.html

3) Your battery is old. PC has a small battery to keep time and setting when it is off. If the energy is low, clock usually resets to a default value. I dont think its your case.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-01-10 04:19:05 -0500

Seen: 8,738 times

Last updated: Jan 12 '12