Ask Your Question

Grub screen menu doesn't show windows 10

asked 2017-07-01 08:06:33 -0500

rajyavardhan gravatar image

updated 2017-07-02 22:04:49 -0500

I am new to fedora, I just installed fedora 25 by enabling legacy mode and disabling safe booting in the BIOS settings. I turned off the quick boot in windows. After installing, fedora is working fine but in the grub screen I can see only fedora. windows is not visible in there. I can access the file system of windows from the fedora filesystem. So I am sure windows is not erased. Can some one please help how can i make windows available on the grub screen.

Thanks in advance.

EDIT:: output of efibootmgr -v

BootCurrent: 0000 Timeout: 0 seconds BootOrder: 0009,3000,3001,3002,3003,3004,3005,3006,3007,3008,2001,2002,2003 Boot0000* EFI HDD Device - ST750LM022 HN-M750MBB PciRoot(0x0)/Pci(0x1f,0x2)/Sata(1,32768,0)/HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)RC Boot0001* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0002* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0003* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0004* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0005* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0006* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0007* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0008* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot0009* Fedora HD(4,GPT,d4df4021-7bc8-447b-9230-76918b7fc128,0x800,0x64000)/File(\EFI\fedora\shim.efi) Boot2001* USB Drive (UEFI) RC Boot2002* Internal CD/DVD ROM Drive (UEFI) RC Boot3000* EFI Internal Hard Disk or Solid State Disk RC Boot3001* EFI Internal Hard Disk or Solid State Disk RC Boot3002* EFI Internal Hard Disk or Solid State Disk RC Boot3003* EFI Internal Hard Disk or Solid State Disk RC Boot3004* EFI Internal Hard Disk or Solid State Disk RC Boot3005* EFI Internal Hard Disk or Solid State Disk RC Boot3006* EFI Internal Hard Disk or Solid State Disk RC Boot3007* EFI Internal Hard Disk or Solid State Disk RC Boot3008* EFI Internal Hard Disk or Solid State Disk RC

output of sudo bash -x grub2-mkconfig

  • set -e
  • prefix=/usr
  • exec_prefix=/usr
  • datarootdir=/usr/share
  • prefix=/usr
  • exec_prefix=/usr
  • sbindir=/usr/sbin
  • bindir=/usr/bin
  • sysconfdir=/etc
  • PACKAGE_VERSION=2.02~beta3
  • host_os=linux-gnu
  • datadir=/usr/share
  • '[' x = x ']'
  • pkgdatadir=/usr/share/grub
  • export pkgdatadir
  • grub_cfg=
  • grubmkconfigdir=/etc/grub.d ++ basename grub2-mkconfig
  • self=grub2-mkconfig
  • grub_probe=/usr/sbin/grub2-probe
  • grub_file=/usr/bin/grub2-file
  • grub_editenv=/usr/bin/grub2-editenv
  • grubscriptcheck=/usr/bin/grub2-script-check
  • export TEXTDOMAIN=grub
  • export TEXTDOMAINDIR=/usr/share/locale
  • TEXTDOMAINDIR=/usr/share/locale
  • . /usr/share/grub/grub-mkconfiglib ++ prefix=/usr ++ execprefix=/usr ++ datarootdir=/usr/share ++ datadir=/usr/share ++ bindir=/usr/bin ++ sbindir=/usr/sbin ++ '[' x/usr/share/grub = x ']' ++ test x/usr/sbin/grub2-probe = x ++ test x/usr/bin/grub2-file = x ++ test x = x ++ grubmkrelpath=/usr/bin/grub2-mkrelpath ++ test x = x ++ grubrpmsort=/usr/sbin ...
edit retag flag offensive close merge delete


Dual boot on the same hard drive?

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-01 10:37:47 -0500 )edit

yes.. and I tried the solution given here. But it doesn't work.

rajyavardhan gravatar imagerajyavardhan ( 2017-07-01 13:53:49 -0500 )edit

What do you get for this command while booted in Fedora

efibootmgr -v
cmurf gravatar imagecmurf ( 2017-07-01 15:59:41 -0500 )edit

I updated the question with the output of efibootmgr -v please have a look

rajyavardhan gravatar imagerajyavardhan ( 2017-07-02 02:41:44 -0500 )edit

I recommend checking if there's a firmware update available for this computer. And then also resinstall shim and grub2-efi to make sure you've got the correct pre-built bootloader binaries installed.

$ sudo dnf reinstall grub2-efi shim

And I'd also look at removing the spare Fedora entries with efibootmgr -b xxxx -B

cmurf gravatar imagecmurf ( 2017-07-02 15:27:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-07-01 15:58:01 -0500

cmurf gravatar image

I just installed fedora 25 by enabling legacy mode

Because of this, you cannot do what you want. Legacy mode means you have a version of GRUB that cannot boot a non-legacy (UEFI) version of Windows. The easiest solution is to revert that change (disable legacy mode, reenable secure boot), and then reinstall Fedora.

edit flag offensive delete link more


When I installed first time, I installed in UEFI mode as you mentioned. At that time GRUB screen was not shown, system was directly booting into windows 10. So I followed this approach. Now Windows is not coming on GRUB. Anyway now I disabled Legacy mode and re enabled secure mode.Even then I can't boot into windows. Its booting into GRUB screen and I can see only Fedora.

rajyavardhan gravatar imagerajyavardhan ( 2017-07-02 02:36:45 -0500 )edit

from a terminal in fedora, run sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg and see if it finds the windows partition now. after running that command, run reboot and see if the grub menu is fised.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-07-02 08:19:04 -0500 )edit

Generating grub configuration file ... Found linux image: /boot/vmlinuz-4.8.6-300.fc25.x8664 Found initrd image: /boot/initramfs-4.8.6-300.fc25.x8664.img Found linux image: /boot/vmlinuz-0-rescue-6d9e8e7f0d59478d82b1202530b9135f Found initrd image: /boot/initramfs-0-rescue-6d9e8e7f0d59478d82b1202530b9135f.img error: syntax error. error: Incorrect command. error: syntax error. error: Incorrect command. error: syntax error. Syntax error at line 129 Syntax errors are detected in generated GRUB config file. Ensure that there are no errors in /etc/default/grub and /etc/grub.d/* files or please fi

rajyavardhan gravatar imagerajyavardhan ( 2017-07-02 12:44:28 -0500 )edit

file a bug report with /boot/efi/EFI/fedora/ file attached. this is the output. Do you know what does it mean?

rajyavardhan gravatar imagerajyavardhan ( 2017-07-02 12:45:48 -0500 )edit

Need the output from both of these. Something's broken, and also there are too many duplicate NVRAM entries which is suspicious.

sudo bash -x grub2-mkconfig
sudo os-prober
cmurf gravatar imagecmurf ( 2017-07-02 15:02:28 -0500 )edit

Question Tools

1 follower


Asked: 2017-07-01 08:06:33 -0500

Seen: 856 times

Last updated: Jul 02 '17