Ask Your Question

Fedora 18 LibraOffice not spell checking

asked 2013-01-21 21:30:18 -0500

mcasperson gravatar image

updated 2014-09-30 09:12:09 -0500

mether gravatar image

I have just installed Fedora 18 with LibraOffice, and the spell checker does not work with the language in the current document (which is set to Australian). What do I need to install to get the spell checking working?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2013-01-21 21:30:57 -0500

mcasperson gravatar image

Turns out all I needed to do was run

sudo yum install libreoffice-langpack-en
edit flag offensive delete link more

answered 2015-09-09 08:59:05 -0500

letlhwai gravatar image

updated 2015-09-09 08:59:53 -0500

Spell checking of libreoffice as well as of evolution can be done wit hunspell. In Fedora 22, a sudo dnf search hunspell | less will list the available languages. Then, you can add languages by sudo dnf install hunspell-xy , e.g. sudo dnf install hunspell-de for the German language.

It is not necessary to install complete language-packages (which affect the surfaces of programs and more) to extend the options of spell checking.

edit flag offensive delete link more


Why are you answering a two-year-old question about Fedora 18?

sideburns gravatar imagesideburns ( 2015-09-09 11:39:35 -0500 )edit

Because this question is shown when someone searches for "spell check evolution" or "spell check libreoffice" or similar. I was dissatisfied with the existing answer, searched myself for a solution and added it after I found one. As I wrote, the answer is valid for Fedora 22.

letlhwai gravatar imageletlhwai ( 2015-09-09 12:20:08 -0500 )edit

answered 2013-11-10 16:58:32 -0500

Thanks, this is great news! This was perplexing me for the longest time. It makes me wonder, why isn't this done by default?

edit flag offensive delete link more

Question Tools


Asked: 2013-01-21 21:30:18 -0500

Seen: 3,059 times

Last updated: Sep 09 '15