Ask Your Question
0

Atheros QCA9377 Wifi Adapter (rev 31) not working on Workstation 25

asked 2017-06-24 08:22:17 -0500

kmy gravatar image

Hello,

I just installed Fedora Workstation 25 on a Lenovo V510 laptop, updated kernel to

uname -r
4.11.5-200.fc25.x86_64

I can not get the wifi Adapter to work

lspci | grep -i wireless
03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

I tried to put the files of the firmware and the solution provided by the backport. Neither work.

For the second, I'm getting a compilation error each time.

# make    
make[5]: « conf » is up to date.
boolean symbol HWMON tested for 'm'? test forced to 'n'
boolean symbol HWMON tested for 'm'? test forced to 'n'
#
# configuration written to .config
#
Building backport-include/backport/autoconf.h ... done.
  CC [M]  /root/backports-20160324/compat/main.o
In file included from /root/backports-20160324/backport-include/backport/backport.h:7:0,
             from <ligne-de-commande>:0:
./include/asm-generic/qrwlock.h: Dans la fonction « __qrwlock_write_byte »:
/root/backports-20160324/backport-include/linux/kconfig.h:25:28: erreur : implicit declaration of function « config_enabled » [-Werror=implicit-function-declaration]
 #define IS_BUILTIN(option) config_enabled(option)

Installing these didn't help.

dnf install git cmake rpm-build gcc-c++ libstdc++-devel gtk2-devel wxGTK-devel mesa-libGLU-devel mesa-libGL-devel gettext bzip2-devel portaudio-devel

Is that revision of the adapter supported and how can I get it to work ? Thank you

edit retag flag offensive close merge delete

Comments

Mate, do you have decision for this problem, because I have the same laptop and same problem too. I try everything, but I'm new with Linux and can't start this wifi driver....

Ferio gravatar imageFerio ( 2017-10-04 11:50:51 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2017-06-27 14:41:02 -0500

sixpack13 gravatar image

updated 2017-06-27 14:54:56 -0500

just do:

dnf install linux-firmware

will install linux-firmware-20170622

check:

ls -l /lib/firmware/ath10k/QCA9377/hw1.0/

reboot

P.S. is your wifi card enabled in your BIOS, too ?

edit flag offensive delete link more

Comments

That didn't help. I have a dual boot system and the card is working fine on the second system (Windows 10). I also tried the last version of Kali on a live usb and the WiFi worked smoothly (I think I'll wait for the 07/11)

kmy gravatar imagekmy ( 2017-07-03 12:17:36 -0500 )edit
0

answered 2017-06-25 11:25:07 -0500

sixpack13 gravatar image

updated 2017-06-25 11:37:44 -0500

lspci -nnv

02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30)
    Subsystem: Foxconn International, Inc. Device [105b:e09a]

This is working OOFB in F25/26. But doesn't display the right speed in network manager, though. The newest firmware is in Fedora (24-27), but did work with the aged one.

https://koji.fedoraproject.org/koji/packageinfo?packageID=9736
https://github.com/kvalo/ath10k-firmware
http://lists.infradead.org/pipermail/ath10k/2017-June/thread.html
edit flag offensive delete link more

Comments

Thanks @sixpack13 Do I need to install all the firmware RPMs ? else how do I know which to install ?

kmy gravatar imagekmy ( 2017-06-25 12:25:03 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2017-06-24 08:22:17 -0500

Seen: 1,853 times

Last updated: Jun 27 '17