Ask Your Question

No audio in Wine

asked 2017-06-16 20:09:13 -0500

thesuperpapagai gravatar image

I am trying to run games in Wine on Fedora 25 via PlayOnLinux, however when they load, none of them have audio. I was able to play the same games fine on other distros, but they do not work with Fedora. Using a different version of WIne also does not fix this problem.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-06-17 02:28:39 -0500

fcomida gravatar image

Wine can output sound through alsa and pulseaudio. In Fedora there is wine-pulseaudio but since you are installing wine through Playonlinux you probably need to install alsa-plugins-pulseaudio `

edit flag offensive delete link more



I already have wine-pulseaudio, wine-alsa and alsa-plugins-pulseaudio installed

thesuperpapagai gravatar imagethesuperpapagai ( 2017-06-17 21:41:03 -0500 )edit

Since PlayOnLinux scripts usually install and use different versions of wine for each game/program, system-wide wine installation isn't relevant in many cases. Anyway have you run winecfg and looked at audio section there? There's also a test audio button. I'm on F24, no audio problems in wine at all here.

fcomida gravatar imagefcomida ( 2017-06-18 01:17:41 -0500 )edit

After a lot of messing about with Wine I found the very best version was the official stable version direct from the creators:

sudo dnf config-manager --add-repo
sudo dnf install winehq-stable

This version has pulse audio installed out-the-box, you should not need to do anything else to get sound.

David-LDA gravatar imageDavid-LDA ( 2017-06-18 05:43:19 -0500 )edit

When I use the Test Audio button I get sound, but I don't get sound in the wine game itself.

thesuperpapagai gravatar imagethesuperpapagai ( 2017-06-18 07:01:43 -0500 )edit

@thesuperpapagai as I said each game on POL has its own version of wine installed under ~/.PlayOnLinux/wine/. You must select a game and run configure and then winecfg from there. I'm not sure whether those local installations of wine have proper support for pulseaudio or not and if this is the case whether your system is properly configured to output sound for alsa only programs through alsa-plugins-pulseaudio or not. Do you have ~/.asoundrc in your home? It should look like this

fcomida gravatar imagefcomida ( 2017-06-18 08:46:00 -0500 )edit

answered 2017-06-16 21:41:24 -0500

Did you build WINE yourself? WINE requires OSSv4 at compile-time to play most sound. If you didn't build it yourself, you might want to give that a try. The instructions to do so can be found here.

edit flag offensive delete link more


Where did you get this information?

fcomida gravatar imagefcomida ( 2017-06-17 02:31:48 -0500 )edit

@fcomida hi downvoter...

@Barrelwolf38087 OSSv4 isn't used anymore in moderns linux distros... the problem is here:

davidva gravatar imagedavidva ( 2017-06-18 00:20:30 -0500 )edit

@davidva ?????

fcomida gravatar imagefcomida ( 2017-06-18 01:01:08 -0500 )edit

@fcomida I got that information when I built WINE from source of Fedora. Had to build OSS, too. Unfortunately, that installation is gone.

Barrelwolf38087 gravatar imageBarrelwolf38087 ( 2017-06-18 22:31:54 -0500 )edit

Question Tools

1 follower


Asked: 2017-06-16 20:09:13 -0500

Seen: 993 times

Last updated: Jun 17 '17