Ask Your Question

Steam not starting up (missing libc & low disc space)

asked 2017-06-11 11:21:12 -0500

MiKu gravatar image

updated 2017-06-11 17:06:27 -0500

When I type "steam" into terminal following messages are presented:

[miku@localhost ~]$ steam
Repairing installation, linking /home/miku/.steam/steam to /home/miku/.local/share/Steam
Running Steam on fedora 25 64-bit
STEAM_RUNTIME is enabled automatically
Unpack runtime failed, error code 1
Error: Couldn't set up the Steam Runtime. Are you running low on disk space?
Error: You are missing the following 32-bit libraries, and Steam may not run:
/home/miku/.local/share/Steam/ line 712: /home/miku/.local/share/Steam/ubuntu12_32/steam: No such file or directory
/home/miku/.local/share/Steam/ line 444: no match: ssfn*

I have over 340 GB of free space on /home partition Interestingly enough "locate" returns the following:

[miku@localhost ~]$ locate

Indicating (at least afaik) there is 32-bit version of libc I have previous config files of steam, but moving both ~/.steam and ~/.local/share/Steam did not changed anything aside from user agreement popping up.


after doing the following:

sudo dnf remove steam
mv ~/.local/share/Steam ~/.local/share/Steam-old
sudo dnf install steam

result is:

[miku@localhost ~]$ steam
Setting up Steam content in /home/miku/.local/share/Steam
Running Steam on fedora 25 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/miku/.local/share/Steam/ line 713:  7812 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
/home/miku/.local/share/Steam/ line 444: no match: ssfn*
edit retag flag offensive close merge delete


Same problem here. I think this may be upgrade-related. I have upgraded from F24 to F25 recently, and hadn't started steam yet. dnf reinstall steam fixed the problem for me.

florian gravatar imageflorian ( 2017-06-12 07:55:35 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-06-11 13:32:22 -0500

sideburns gravatar image

Welcome to ask.fedora. I see that you're running Fedora 25, but Steam is trying to use the directory /home/miku/.local/share/Steam/ubuntu12_32/steam which implies that you're trying to use an installer built for Ubuntu 12. Instead of using an obsolete installer that you found at some random website, why don't you just install it using this:

sudo dnf install steam

This will get you the most recent version, customized for Fedora. Of course, you need to have the repo rpmfusion-nonfree-updates installed, but you should have all of the rpmfusion repos installed anyway.

edit flag offensive delete link more


Forgot to mention that, but I used exactly that command to install Steam. But removing steam and ~/.local/share/Steam and then installing steam again results in a different bug

MiKu gravatar imageMiKu ( 2017-06-11 17:00:27 -0500 )edit

OK, that doesn't explain why it was trying to put steam in that specific directory, but that's no longer important. It's also nice that you have both 32 and 64-bit versions of but there's only one version of steam, presumably 32-bit. You may be better off asking at the Steam Community Forum as this probably isn't Fedora specific.

sideburns gravatar imagesideburns ( 2017-06-11 17:31:19 -0500 )edit

I have the same on problem on my F25-x86_64 machine, including the same error message that let's you think some Ubuntu is going on here (Yes, I only used dnf to install steam from fedora repos). I fixed it by reinstalling steam: dnf reinstall steam

florian gravatar imageflorian ( 2017-06-12 07:56:40 -0500 )edit

Question Tools

1 follower


Asked: 2017-06-11 11:21:12 -0500

Seen: 688 times

Last updated: Jun 11 '17