Fedora 25: How to mount NTFS partitions

asked 2017-06-11 03:22:10 -0500

Sorimis gravatar image

updated 2017-06-11 18:04:23 -0500

Hi all! I try to change to Linux for good after years of excessive Windows using. To make it more comfortable I need to make some changes so I wanted to start with mounting the NTFS-partitions that they're available when Fedora booted. I thought, that I know how to handle the fstab but nothing works. The line I want to start with is:

UUID="35F2A5B32FB1AB4B"         /mnt/Musik   ntfs uid=sorimis,gid=1001,umask=0022   0   0 |

Then I get two errors. The first, when I didn't temporarily mount it:

sudo mount -a | mount: can't find UUID="35f2a5b32fb1ab4b" | 'gid' option needs a decimal value | so I thought when it doesn't find the UUID that blkid offers me I mount it temporarily and it gives me the following error:

sudo mount -a | Mount is denied because the NTFS volume is already exclusively opened.

The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command.

| 'gid' option needs a decimal value | I have no idea what the problem is, but I want the NTFS partitions work automatically on my Fedora.

Thanks for help

edit retag flag offensive close merge delete

Comments

troubleshooting ideas: 1) try without the quotes around the UUID; 2) try replacing UUID="35f2a5b32fb1ab4b" with e.g. /dev/sdb2; sorry, no idea about the gid

hfs99 gravatar imagehfs99 ( 2017-06-11 07:16:40 -0500 )edit
1

Please update the title of your post this is about mounting hard drives, and has nothing related to network printers. As far as mounting windows controlled partitions, you MUST disable the windows FAST shutdown feature, so that windows actually dismounts the partition properly. I dual boot, and share a hard drive with windows, and have no problems automatically mounting from fstab when linux starts. YOU must disable FAST SHUTDWN in windows 10 to get this to work properly.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-11 07:51:13 -0500 )edit

I'm not sure just what you're trying to do with that umask, but I have an old DOS partition mounted as msdos. When I was setting things up, it would always mount read only, even if I specified r/w, until I put umask=0000 as my only mount option. This basically overrides any default restrictions on how I can use the drive, giving me complete freedom to do as I wish. Unless this is a multi-user system, and you need to restrict access by others, you probably don't need any options except the umask.

sideburns gravatar imagesideburns ( 2017-06-11 21:36:27 -0500 )edit

Thanks for the answers, so here is what I made. I replaced the UUID with /dev/sdb1 that is the place as fdisk told me. The change is, that Fedora doesn't start in rescue mode, but the partitions don't appear anymore when Fedora is running. Disabling FAST SHUTDOWN is a really great idea but I still have Windows 7 and its not available there. I chnaged umask and nothing changed.

And this is only a dual boot Desktop computer and I want to use the NTFS partitions without mounting it everytime before using.

Sorimis gravatar imageSorimis ( 2017-06-13 05:44:48 -0500 )edit

Disable FAST SHUTDOWN is not just a suggestion. It is a requirement for linux to be able to mount any partition that windows touched. Windows will automatically mount the partition again, when you boot, Find the FAST SHUTDOWN and turn it off. I run dual boot with Windows 10 and Fedora. They share a 1.5TB NTFS hard drive just fine. it automounts with Fedora, from the fstab file.

SteveEbey73701 gravatar imageSteveEbey73701 ( 2017-06-13 07:49:02 -0500 )edit