Error mounting ntfs partition on Fedora 18

asked 2013-01-19 11:08:59 -0500

encypter gravatar image

updated 2015-04-11 23:58:59 -0500

mether gravatar image

Hi, I have a dual boot system with Win8 and Fedora 18. So I have three partitions, Win8, Fedora 18 and another ntfs partition where I keep my files. I tried to mount this last partition in Fedora and I get this error message:

Error mounting /dev/sda4 at /run/media/myuser/Dados: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda4" "/run/media/myuser/Dados"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 1).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda4': Operação não permitida
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

How can I solve it? In Win8 I can access my files normally...

Thanks for the further help!

edit retag flag offensive close merge delete

Comments

Boot Windows, have it run scandisk (or whatever it's called now) on that partition and do a complete reboot. I'm not making this an "answer" because I don't know for sure if this is what's needed, but most of the time it works. Good luck, and let us know how it goes.

sideburns gravatar imagesideburns ( 2013-01-19 14:41:20 -0500 )edit

There's a section in the release notes on this. Win8 has a 'fast reboot' or 'Fast start' feature that can be disabled to prevent metadata caching, i believe.

randomuser gravatar imagerandomuser ( 2013-01-22 13:50:19 -0500 )edit

Please take a look a the following very detailed answere on aks ubuntu http://askubuntu.com/questions/145902... .

leog gravatar imageleog ( 2016-12-10 08:26:33 -0500 )edit