Ask Your Question
1

How can I make my rtlwifi chip work?

asked 2011-12-11 12:36:33 -0500

evanp gravatar image

updated 2014-09-29 01:18:26 -0500

mether gravatar image

I've got Lenovo Thinkpad X201 running Fedora 16. It has a built-in RealTek RTL8192se wireless chip.

I used to build my own realtek drivers for the 2.6.x kernels, but I haven't done that since Linux 3.0. The drivers on the 2.6 kernels were pretty fragile around suspend/restore time, but otherwise passable. Now, I have a really hard time getting connected at all.

When trying to connect to my home network, 802.11n with WPA2 Personal security, the network manager asks for the network password a few times before giving up. /var/log/messages has a few lines like:

Dec 11 13:31:31 cherita NetworkManager[986]: <warn> Activation (wlan0/wireless): association took too long.

I'm working around the problem for now by using a USB network card, but I'd like to know if others are having similar problems and if there are known workarounds.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-12-13 00:36:28 -0500

SoumyaC gravatar image

There is a same problem asked here before in #Askfedora -

http://ask.fedoraproject.org/question/291/realtek-wireless-rtl8191sevb-on-fedora-15-and-16

I suggested to use wicd to him and it worked there.

If you don't have fascinations for NetworkManager you can just try to remove NetworkManager and make your rtlwifi chip work with wicd.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-12-11 12:36:33 -0500

Seen: 1,202 times

Last updated: Dec 13 '11