Ask Your Question
1

x0vncserver -display :0 -> No protocol specified

asked 2017-06-03 13:12:22 -0500

fc gravatar image

Hello,

I am trying to open a VNC to display :0 in Fedora 25 but I got this error.

[myname@myserver ~]$ x0vncserver -display :0 --geometry=1400x900+0+0 -PasswordFile=/home/myname/.vnc/passwd No protocol specified x0vncserver: unable to open display ":0"

I have searched internet for a solution but I always end up in old information which seems not to be accurate anymore.. Has someone found the same issue? How to solve this ?

Thanks, Slid4r303

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-06-03 17:00:51 -0500

florian gravatar image

updated 2017-06-03 17:18:54 -0500

That sounds like a problem of TigerVNC not being able to run under Wayland.

Please try again in an X.org and report back (On login screen, after clicking your username, click the little gear, and select Xorg session, then login).

If that works, and you want to make X.Org your default display server, check out this post

You also may want to check if your problem is listed here or here

EDIT : A quick search reveals that your question has been asked and answered already: https://ask.fedoraproject.org/en/ques... and some more information: https://github.com/TurboVNC/turbovnc/... and https://github.com/TigerVNC/tigervnc/...

And here is another workaround

edit flag offensive delete link more
0

answered 2017-06-05 04:14:55 -0500

fc gravatar image

Hello Florian,

Thank you for your answer.

Trying to logging in with xorg was ok but still when start x0vncserver the same result is found. Also tried the WA but still no good.

I am able to start (tiger)vncserver either via systemctl or at user shell - this works good following the Fedora 25 Admin Guide. But what I am trying to accomplish is to remote desktop the DISPLAY=:0

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-06-03 13:12:22 -0500

Seen: 3,436 times

Last updated: Jun 03 '17