Ask Your Question
1

vga=0x307 is deprecated, but can't get gfxmode to work

asked 2011-11-08 09:43:51 -0500

caddr gravatar image

updated 2011-11-10 08:57:04 -0500

I've tried setting in /etc/default/grub

GRUB_GFXMODE=1280X1024x16
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_TERMINAL=gfxterm

rebuilt grub.cfg with

grub2-mkconfig -o /boot/grub2/grub.cfg

But it doesn't work.

How does this work?

Thanks.

edit retag flag offensive close merge delete

6 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-08 10:50:20 -0500

kiilerix gravatar image

updated 2011-11-10 09:47:01 -0500

Configuration of graphical boot loader with grub2 is currently a big tricky.

First you have to convert a font, for example with:

grub2-mkfont --output=/boot/grub2/unicode.pf2 /usr/share/fonts/dejavu/DejaVuSansMono.ttf

Then, in /etc/default/grub add:

GRUB_TERMINAL=gfxterm

and then you run:

grub2-mkconfig -o /boot/grub2/grub.cfg

and reboot

edit flag offensive delete link more
0

answered 2011-11-08 09:57:13 -0500

tuxdna gravatar image

@caddr

Was your issue resolved? If yes, could you post the solution here.

I found a nice article on the topic:

http://harrison3001.blogspot.com/2009/09/grub-2-graphical-boot-tips-to-set.html#.TrlQHT2ZBMY

edit flag offensive delete link more
0

answered 2011-11-13 09:29:05 -0500

ZenDark gravatar image

Thanks!!! I was searching for this...

And if you put the next line, you'll get verne background image at boot (I was missing this from my old fedora 15) GRUB_BACKGROUND=/boot/verne.tga

/boot/verne.tga converted from verne.jpg

edit flag offensive delete link more
0

answered 2011-11-11 19:50:09 -0500

skytux gravatar image

this solution from @kiilerix doesn't work for me in F16 x86_64, fonts didn't change...any ideas?

edit flag offensive delete link more
0

answered 2011-11-08 12:15:50 -0500

evillagr gravatar image

tuxdna solution works fine. You can use any .ttf.

edit flag offensive delete link more
0

answered 2011-11-13 05:56:47 -0500

hedayat gravatar image

Apparently, the GRUB_TERMINAL=gfxterm line is no longer required (actually it generates an error message when loading grub2).

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2011-11-08 09:43:51 -0500

Seen: 9,144 times

Last updated: Nov 13 '11