Ask Your Question
0

Need mysql-libs(x86-64) = 5.5.21-1.fc16

asked 2012-04-04 23:10:44 -0500

smitty10 gravatar image

updated 2012-04-04 23:11:50 -0500

Hi everyone,

I'm pretty new to Fedora and I'm attempting to install mysql right now. After I type in "yum install mysql mysql-server", I get an error at the end that says:

Error: Package: mysql-5.5.21-1.fc16.x86_64 (updates)
       Requires: mysql-libs(x86-64) = 5.5.21-1.fc16
       Installed: mysql-libs-5.5.22-1.fc16.x86_64 (@updates-testing)
           mysql-libs(x86-64) = 5.5.22-1.fc16
       Available: mysql-libs-5.5.14-3.fc16.x86_64 (fedora)
           mysql-libs(x86-64) = 5.5.14-3.fc16
       Available: mysql-libs-5.5.21-1.fc16.x86_64 (updates)
           mysql-libs(x86-64) = 5.5.21-1.fc16

I've been looking everywhere to try and find "mysql-libs(x86-64) = 5.5.21-1.fc16" but all I can seem to find is the one that says it's already installed. Any help that anyone can offer me would be really appreciated! :)

Thank you, Steffen

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-04 23:59:06 -0500

Remi gravatar image

From input, it seems you have installed mysql-libs 5.5.22 from updates testing.

2 solutions:

Install mysql from updates testing

yum --enablerepo=updates-testing install mysql

Downgrade mysql-libs to version in stable repository before installing mysql

yum downgrade mysql-libs
yum install mysql
edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-04-04 23:10:44 -0500

Seen: 326 times

Last updated: Apr 04 '12