Ask Your Question
0

Issues accessing samba share

asked 2017-05-28 15:23:34 -0500

updated 2017-05-28 19:39:38 -0500

I am currently working on setting up a samba share. I am going to be sharing a raid array mounted at /storage, but I saw someone saying that they had an issues sharing a directory that is not on the boot volume so I am working with a /testsmb directory I made. The permissions are set 0755. I cannot connect to the samba share. The following is my smb.conf ... Any ideas?

[global]
        workgroup = WORKGROUP
        security = user
        interfaces = lo, enp2s0, 192.168.2.101/24
        bind interfaces only = yes
        hosts allow = 127.0.0.1, 192.168.2.1, 192.168.254.100

        passdb backend = tdbsam

        printing = cups
        printcap name = cups
        load printers = yes
        cups options = raw


[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes

[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = root
        create mask = 0664
        directory mask = 0775

[storage]
        comment = Storage.Subdomain.Domain.tld
        path = /testsmb
        valid users = matthew
        browsable = yes
        read only = no
        create mask = 0755
edit retag flag offensive close merge delete

Comments

Perfect, thank you!

mdooley47 gravatar imagemdooley47 ( 2017-05-29 19:33:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-05-29 06:37:51 -0500

sixpack13 gravatar image

updated 2017-05-29 06:38:40 -0500

... and did you read about selinux in your /etc/samba/smb.conf.example ?

check your smb.conf with testparm -v

edit flag offensive delete link more

Comments

@aeperezt Thank you! This is the correct answer I was looking for. Since it is a comment I've quoted it here:

Did you open the samba ports on the firewall this should do it firewall-cmd --add-service=samba

mdooley47 gravatar imagemdooley47 ( 2017-05-29 19:32:54 -0500 )edit

I put SELinux in permissive mode. @aeperezt got it right, I didn't realize Fedora had a firewall active by default.

mdooley47 gravatar imagemdooley47 ( 2017-05-29 19:35:02 -0500 )edit
0

answered 2017-05-28 20:22:33 -0500

aeperezt gravatar image

Did you open the samba ports on the firewall this should do it firewall-cmd --add-service=samba

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-05-28 15:23:34 -0500

Seen: 164 times

Last updated: May 29 '17