Ask Your Question
1

tmux won't load powerline unless started with -v

asked 2017-05-28 07:37:00 -0500

Velinion gravatar image

Long time user of Ubuntu/Mint who thought he'd give Fedora a try after many many years.

Getting things set up (switched to zsh, getting config file set, etc) and ran into an odd issue. Installed powerline using dnf and set it up in zsh with no issue, and vim with some minor troubleshooting, but tmux is being weird.

If I start tmux normally, powerline does not load. If I run "tmux -v" instead, powerline works perfectly inside tmux. Honestly, I momentarily considered just aliasing tmux to tmux -v, but I didn't want to spew log files all over the place.

My ~/.tmux.conf is very simple still:

set-option -g default-shell /bin/zsh
set -g mouse on
set-option -g default-terminal "xterm-256color"

# Enable Truecolor
set -ga terminal-overrides ",xterm-256color:Tc"

# Set up Powerline
run-shell "powerline-daemon -q"
source "/usr/share/tmux/powerline.conf"

Any ideas how to get this working without verbose logging? Have to say, this is the only time I've had verbose logging suppress a problem rather than helping me find it.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-05-28 17:51:15 -0500

Velinion gravatar image

Never mind - apparently a full reboot fixed the issue which makes little sense to me, but then problem made no sense in the first place, so I guess that's OK.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-05-28 07:29:50 -0500

Seen: 153 times

Last updated: May 28 '17