Ask Your Question
0

How can I make Fedora 20 run faster from my USB drive?

asked 2017-05-20 09:32:14 -0500

FedoraUser500 gravatar image

Installed Fedora 20 on USB drive. Latest version I have. Runs fine from CD, taskmanager is under 25% with CD but off USB it frequently goes to 100% and gets stuck. Installing anything is a nightmare.

Should I upgrade? Get a used hard disk?

edit retag flag offensive close merge delete

Comments

there are too many variables to troubleshoot this. Do you have USB 3 ports and the drive is 3.0 ? did you update to the latest version? I recommend you get fedora 25 if you can. Is it a old HDD or pretty new?

jlozadad gravatar imagejlozadad ( 2017-05-20 10:09:04 -0500 )edit

Ports are labeled USB 2.0. USB is Kingston 16GB DataTraveler 101 G2 USB Flash Drive - 10MB/s. brand new. Disable legacy USB on BIOS - USB does not detect. Let me try putting that to auto CPU

$ lscpu Architecture: i686 CPU op-mode(s): 32-bit, 64-bit Byte Order: Little Endian CPU(s): 2 On-line CPU(s) list: 0,1 Thread(s) per core: 1 Core(s) per socket: 2 Socket(s): 1 Vendor ID: GenuineIntel CPU family: 6 Model: 15 Model name: Intel(R) Pentium(R) Dual CPU E2160 @ 1.80GHz

FedoraUser500 gravatar imageFedoraUser500 ( 2017-05-20 23:28:18 -0500 )edit

Trying swappiness 10 then swapiness 1. TOP command shows Firefox using about 800 mb swap memory. Midori is a bit better at 400.

FedoraUser500 gravatar imageFedoraUser500 ( 2017-05-21 05:47:31 -0500 )edit

you are going to have bad performance running from a flash drive.

jlozadad gravatar imagejlozadad ( 2017-05-21 08:28:46 -0500 )edit

Performance is "read speed of 20.64 MB/s and write speed (average) of 9.24 MB/s." according to this site.

That is compared to hard disk speed of 170/110 for the best drives of 2016. So it looks like a drive speed problem - will try with swappiness at 1 and check.

A new Fedora 25 install is recommended over an upgrade online. Will look at this. Anyone know what the swappiness setting of live CD is?

Maybe if I run sysctl -a | grep vm.swappi

FedoraUser500 gravatar imageFedoraUser500 ( 2017-05-23 01:03:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-24 01:09:56 -0500

FedoraUser500 gravatar image

Answering my own question...

How do you make it run faster? Change the swappiness parameter to 10 or zero. Use the Midori browser instead of Firefox, and if possible, open one application at a time.

Getting a used hard disk is a good option, since they are faster, and used one cost very little these days.

Upgrading to Fedora 24 or 25 online is not recommended, and may take a long time, especially with an USB drive. You notice that USB read write speeds are around 20/9 compared to 170/110 for the latest hard disks around these days. The swappiness on live boot is set to a standard value of 60, which means that disk writes are not a problem for the live version, which uses RAM disk.

One option would be to load the OS to RAMDISK like Puppy Linux is said to do. Will check this out next and report.

There is an article here on creating a RAMDISK and setting up autobackup so no data is lost:

http://www.techrepublic.com/article/h...

edit flag offensive delete link more

Comments

1

Upgrade is not only recommended, it is absolutely necessary. Sure, upgrading would take forever on that small and relatively slow USB thumb drive. Just backup your data from the drive and reinstall Fedora 25. (But get a faster USB, or a fast SD card, otherwise you will continue suffering).

florian gravatar imageflorian ( 2017-05-24 10:22:07 -0500 )edit

Ramdisk speeds things a bit, will test more and report.
https://ask.fedoraproject.org/en/ques...

FedoraUser500 gravatar imageFedoraUser500 ( 2017-05-26 09:12:27 -0500 )edit

Kernel panic. Probably due to corruption due to loading incorrect type of RAM drive the one that loads hard disk stuff into memory. I meant to load swap file stuff into memory. Ah well. Reinstalled another flavor of Linux.

FedoraUser500 gravatar imageFedoraUser500 ( 2017-06-01 23:19:10 -0500 )edit

That all makes no sense to me. swap is being used when your RAM is (nearly) full.[1] Now, how should it be possible to relocate your swap to RAM when RAM is (nearly) full? That doesn't work. Get rid of your swap at all, and just don't use more RAM than you have available on your machine. get a faster USB device or SD card!

[1] with swappiness=0 or 1

florian gravatar imageflorian ( 2017-06-02 02:25:20 -0500 )edit

Funny thing is, it actually worked until my kernel panic. The live DVD version runs fairly fast. I would think that the swap area is used when the RAM is full, yes, but the swap file is on a slow USB. So swapping to memory is faster, it avoids a bad strategy of swapping to a slow disk. Now I used tempfs instead of ramfs where the latter does not seem to be affected by unexpected power off.

Read more here

FedoraUser500 gravatar imageFedoraUser500 ( 2017-06-02 03:05:47 -0500 )edit

Question Tools

Stats

Asked: 2017-05-20 09:32:14 -0500

Seen: 295 times

Last updated: May 24 '17