Ask Your Question
0

Rhythmbox doesn't find iPhone 4 running iOS 5 in Fedora 17

asked 2012-07-12 04:23:32 -0500

JiminyCricket gravatar image

I recently installed F17 on my laptop and for whatever reason I cant access my iPhone from Rhythmbox.

It shows up on the Desktop but when I double click I get an error "Unable to mount iPhone - Unhandled Lockdown Error -5"

I have version 1.1.4 of libimobiledevice

when I type dmesg after plugging her in i get a segfault after the phone is recognized on iphone-set-info

[ 4750.465316] ipheth 2-1.1:4.2: Apple iPhone USB Ethernet now disconnected
[ 4752.777036] usb 2-1.1: new high-speed USB device number 6 using ehci_hcd
[ 4752.866530] usb 2-1.1: New USB device found, idVendor=05ac, idProduct=1297
[ 4752.866540] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4752.866546] usb 2-1.1: Product: iPhone
[ 4752.866550] usb 2-1.1: Manufacturer: Apple Inc.
[ 4752.866555] usb 2-1.1: SerialNumber: XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXx
[ 4753.068103] ipheth 2-1.1:4.2: Apple iPhone USB Ethernet device attached
[ 4753.169083] atl1c 0000:04:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
[ 4753.215448] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 4754.588218] iphone-set-info[3090]: segfault at 0 ip 0000003077b06720 sp 00007fff5df8c208 error 4 in libc-2.15.so[3077a00000+1ac000]

Oddly enough, Shotwell recognizes it and was able to download photos.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-07-16 11:07:28 -0500

updated 2012-07-16 11:08:10 -0500

yum install libimobiledevice-utils

idevicepair unpair && idevicepair pair

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-07-12 04:23:32 -0500

Seen: 1,743 times

Last updated: Jul 16 '12