Ask Your Question

Running an executable file in fedora 18 by double clicking

asked 2013-02-19 07:46:13 -0500

c159295 gravatar image

updated 2013-02-21 07:11:24 -0500

FranciscoD_ gravatar image

If you set 'allow executing file as program' in properties the .sh file will running by double click and another click to select to run the file, but all that happen in Fedora 17 and good, but current fedora 18 will not run it this way, you have to open a terminal window and do something and the terminal windows have to stay until my exit that .sh, so my ask is how to run the .sh file directly

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-02-19 08:12:46 -0500

  1. Create your executable file, let's say
  2. Perform a: chmod +x
  3. Open Nautilus, check Preferences - Behavior - Executable Files, put as always ask
  4. Finally, right click your file, and under Properties - Permissions, check Execute as an application

When you double-click your file it will ask you what you want to do with it, you just simply choose Run in console

If still this doesn't work, edit your script and put in the end the following:

exec /bin/bash
edit flag offensive delete link more


Hi @lnxslck - What is the purpose of the exec /bin/bash at the end of the script?

megabyte gravatar imagemegabyte ( 2013-05-22 19:25:45 -0500 )edit

To force it to execute as a bash program

lnxslck gravatar imagelnxslck ( 2013-05-23 12:33:01 -0500 )edit

Question Tools


Asked: 2013-02-19 07:46:13 -0500

Seen: 14,954 times

Last updated: Feb 21 '13