Ask Your Question
2

Only getting Gray Screen when booting into Gnome with kernel > 4.10.8 (Fedora 25)

asked 2017-05-02 09:10:41 -0500

voyager106 gravatar image

I've gone back and forth regarding posting this, but it has me stumped and I can't find any information from others experiencing the issue.

I'm running Fedora 25 with Xorg Gnome. Currently my installed kernels are 4.10.8, 4.10.12 and 4.10.13 (and before the last update, had 4.10.11). Last week I discovered I was not running the latest kernel, so I reboot my machine from 4.10.8 into 4.10.12. Everything seems to happen fine, but when I get to gdm where I should be able to log in, I'm just given a gray screen. I let it sit for a while thinking it might take a bit, but nothing else happens there. I'm able to switch other other TTYs using ctl+alt+F[X], but as far as logging into Gnome, I just can't.

So I did a clean reboot and tried the 4.10.11 kernel. Same issue. Do another clean reboot back into 4.10.8. I'm given the expected log in option and have no issues.

So, this morning, I notice I have the 4.10.13 kernel. I try booting into it and get the blank gray screen. Thinking it might have to do with the fact I'm using Gnome Xorg (even though gdm is Wayland), I boot back into 4.10.8, change it to Gnome (Wayland) and log in. No problems. Do another reboot into 4.10.13, same gray screen. Boot back into 4.10.8, no issues.

One suggestion I found was disabling Wayland for gdm, but when I tried it this morning, I didn't even get a gray screen. Just black.

I've also seen some suggestions it might have to do with having multiple monitors. I'm using my thinkpad docked with 2 monitors. I've not had the chance to try it undocked, though I suspect it would be fine.

I've tried looking through my logs, but nothing is jumping out at me. This is on a Thinkpad t460s with Intel Graphics. Any help is appreciated, thank you.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-05-06 04:31:35 -0500

kelaun gravatar image

Take at look at this thread. This solved it for me.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-05-02 09:10:41 -0500

Seen: 562 times

Last updated: May 02 '17