Ask Your Question
0

How to SSH in a Fedora system using a user who has no set password

asked 2017-04-16 16:43:04 -0500

Andrei Costache gravatar image

I have set-up sshd server on FC25, and I am trying to ssh from an Ubuntu system to the FC system. If I try to ssh as root, it works => ssh set-up is correct at server and client side. However, if I try to connect using a regular user account I have on the Fedora system it does not accept any pasword;

The regular user I am using has no password set (I installed Fedora this way to make the user a member of the administrators group (wheel) but not have a password by itself - blank password field for the user).

So, the question is: what password should I use when trying to ssh using the regular user? (I tried blank as well and it does not work)

edit retag flag offensive close merge delete

Comments

You should probably use a different type of authentication than "passwords". I'll make no claims about this tutorial, and it is outside of standard fedora documentation, but it might prove useful: link text There are probably other ways to make this happen with blank passwords. If you still want to do it that way, then explore "man /etc/ssh/sshd_config" and look at:

#PermitEmptyPasswords no

I have no experience with this setting, please don't listen to me.

lovepump gravatar imagelovepump ( 2017-04-16 17:45:10 -0500 )edit

Your suggestion of setting the

PermitEmptyPasswords yes

solved my problem. Please make an answer out of it, if you wish to claim it. Otherwise I will make it, for others to see.

As to the link, it does describe an interesting way of doing things. However, user a on host A needs to enter the password of user b on host B twice, before it can work. Since user b on host B has no password in my case and the PermitEmptyPasswords is default no on host B, then the procedure would not work in my usecase.

Andrei Costache gravatar imageAndrei Costache ( 2017-04-17 02:13:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-04-17 23:06:52 -0500

Andrei Costache gravatar image

I order to allow users who have no password to login remotely on a Fedora system, one has to set the

PermitEmptyPasswords yes

in the /etc/ssh/sshd_config file (in FC25 the entry is already there but commented (#) and set to a default value of "no");

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-04-16 16:43:04 -0500

Seen: 147 times

Last updated: Apr 17 '17