Ask Your Question
1

Fedora 25 - cannot install steam - othing provides libva-intel-driver(x86-32)

asked 2017-04-15 17:07:06 -0500

stryder0 gravatar image

Every time I attempt to install steam I receive this error:

$ sudo dnf install steam Last metadata expiration check: 0:07:36 ago on Sat Apr 15 17:50:33 2017. Error: nothing provides libva-intel-driver(x86-32) needed by steam-1.0.0.53-1.fc25.i686 (try to add '--allowerasing' to command line to replace conflicting packages)

I have no clue what is causing this and after a while searching I could not find an answer online.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-04-16 08:33:13 -0500

SteveEbey73701 gravatar image

updated 2017-04-16 08:33:33 -0500

I used negativo rpm to get steam to install, it had the libva file that you need. Search the forums for negativo for instruction to add the repository.

edit flag offensive delete link more
0

answered 2017-04-17 10:12:09 -0500

genodeftest gravatar image

libva-intel-driver is not a package in Fedora standard repositories. Where did you get the steam installer? It should (have) come with a guide that tells you how to enable other package repositories such as RPMFusion. The package is e.g. provided by rpmfusion-free(-updates). See https://rpmfusion.org/Configuration for how to enable this repository.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-04-15 17:07:06 -0500

Seen: 985 times

Last updated: Apr 17 '17