Ask Your Question

Fedora 25 hangs on unplugging laptop charger

asked 2017-04-15 04:52:12 -0500

Hi, I posted this issue in Reddit, but figured out that this would be a better place to post this issue.

Hardware: HP Probook 4445s, AMD A8-4500m Issue: Fedora 25 would hang after unplugging laptop charger on a 4 yo. laptop (HP Probook 4445s)

This issue only started when I updated (dnf update) a fresh installation of Fedora 25. This issue never happened in the distro installed before switching to fedora (ubuntu).

I also tried going through the terminal (ctrl+alt+f3) and then unplugged the charger, this is what happened:

Other info: - This does not happen when I select Fedora (4.8.6-300.fc25.x86_64) 25 on the boot screen. This issue only happens when I select the newer Fedora (4.10.8-200.fc25.x86_64) 25.

Other issues: Wifi connection is weaker (would need to get nearer to the wifi source) than before when it was still running on ubuntu. But I'm aware that there's no real driver support for Broadcom 4313GN 802.11b/g/n, however, I would still like to drop this in since this issue did not exist if the laptop is running on Ubuntu 16.10.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2017-04-17 10:52:51 -0500

genodeftest gravatar image

updated 2017-04-17 16:19:58 -0500

In your video, one can see that there is a kernel crash. After you rebooted your kernel, can you get the kernel crash reported using gnome-abrt? If not, can you open a terminal and run journalctl -b -1 ("-1" means previous boot), then copy the output? (the --since option of journalctl might come handy, please see the man page for details. Also, input redirection to a file might help). You could e.g. run journalctl -b -1 --since="2017-04-17 12:30" > kernel-error.txt to save the output in a file in your current working directory. You should have a look at where your bug might already be listed. If not, please open a new bug report. Make sure to add the word "Regression" to the bug description.

Kernel versions: Your kernel 4.10.8 is old, you might want to update to 4.10.9 or later. Be careful, since this may remove the older (working) kernel. I suggest you use dnf to upgrade after changing the installonly_limit in /etc/dnf/dnf.conf , this way you can have the old (working) kernel installed and still update your computer. Make sure to read the man page "dnf.conf" for details. If the issue is not being solved within a few days, you should "bisect" kernel versions to hunt down which update introduced the kernel. This means that you need to install kernel versions in the range between 4.8.6 to 4.10.8. "bisect"ing means that you have a span and start in the middle, e.g. 4.9.7. If the issue is present with 4.9.7 too, continue between 4.8.6 to 4.9.7, e.g. 4.9.0. If the issue is not present with 4.9.7, it was introduced later, so continue with 4.10.0 for example. This way you can determine the update the bug was introduced. Have a look at where you can download the packages manually if they are not in the repositories any more.

Additional info: and

edit flag offensive delete link more


Thanks, weird that this board did not email me when you replied to this post.

Anyways, I also tried in Arch using linux-lts (kernel version 4.9.24-1), and it still crashed. So I'm assuming that the latest version where the crash does not happen is 4.8.6-300. I also tried using 4.10.11-1 (in arch), and the issue still happens. I since then switched back to Fedora since at least I got the option to switch to 4.8.6-300 in the GRUB menu in case I need my laptop disconnected from the powersource.

I will try to get the kernel crash report later when I get home, and post it here just for an update.

dcefram gravatar imagedcefram ( 2017-04-24 01:54:59 -0500 )edit

Question Tools



Asked: 2017-04-15 04:52:12 -0500

Seen: 45 times

Last updated: Apr 17 '17