Ask Your Question

gnome ignoring disable-user-list

asked 2017-03-31 10:13:59 -0500

shimm gravatar image

I tried to disable gnome user list on login screen on fedora 25. But it is just not working.


Content of ./db/gdm.d/00-login-screen


Content of ./profile/gdm


even after dconf update, remove db and dconf update, reboot or restart gdm. The user list keeps being shown.

Any suggenstions to fix this?

edit retag flag offensive close merge delete


Move to answer

anotherlinuxuser gravatar imageanotherlinuxuser ( 2017-04-22 01:03:17 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-04-22 01:10:39 -0500

This worked on my systems to disable the the user list:

Create a file /etc/dconf/db/gdm.d/00-login-screen with contents like:



banner-message-text='Enter a valid Domain or Linux user name to begin.\nUnauthorized access is prohibited by law. Access to this network may be monitored and/or recorded for quality assurance, security, performance, and/or maintenance purposes.'




Then I ran:

dconf update

Then I renamed gdm's existing dconf user file to force gdm to create a new dconf user file:

mv /var/lib/gdm/.config/dconf/user /var/lib/gdm/.config/dconf/

Finally, I rebooted the system, after which gdm had a new dconf user file, and the the login screen was configured the way I wanted it. You may want different text and reboot access, of course.

Hope it helps.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-03-31 10:13:59 -0500

Seen: 494 times

Last updated: Apr 22 '17