Ask Your Question
0

Moving from Gnome to KDE - Fedora 25

asked 2017-03-03 08:30:22 -0500

achede_hd gravatar image

I followed the guide https://fedoraproject.org/wiki/SwitchingDesktopEnvironments

but I did different hehe , I did not used "sudo" , , i login as root in terminal and then install the KDE package

Maybe this is the root cause of the issue

[[ Could not start kdeinit5. Check your installation.]]

[[ Okay ]]

[local1@localhost ~]$ startkde ksplashqml: error while loading shared libraries: libKF5WindowSystem.so.5: cannot open shared object file: No such file or directory startkde: Starting up... dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.InvalidArgs: Invalid environment assignments /usr/bin/kdeinit5: error while loading shared libraries: libKF5WindowSystem.so.5: cannot open shared object file: No such file or directory startkde: Could not start kdeinit5. Check your installation.

[root@localhost bin]# ll kdeinit* -rwxr-xr-x. 1 root root 56896 Feb 10 05:44 kdeinit4 -rwxr-xr-x. 1 root root 15408 Feb 10 05:44 kdeinit4shutdown -rwxr-xr-x. 1 root root 15408 Feb 10 05:44 kdeinit4wrapper -rwxr-xr-x. 1 root root 57176 Feb 22 12:40 kdeinit5 -rwxr-xr-x. 1 root root 15560 Feb 22 12:40 kdeinit5shutdown -rwxr-xr-x. 1 root root 15560 Feb 22 12:40 kdeinit5wrapper

Please help!

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2017-03-03 12:44:00 -0500

achede_hd gravatar image

updated 2017-03-04 04:29:06 -0500

deadrat gravatar image

This solved the issue

dnf install kf5-kwindowsystem --best
edit flag offensive delete link more
0

answered 2017-03-03 08:40:08 -0500

achede_hd gravatar image

I tried to install the required RPM , but it has MORE dependencies:

[local1@localhost Downloads]$ rpm -Uvh kf5-kwindowsystem-5.27.0-1.fc25.i686.rpm error: Failed dependencies:

libQt5Core.so.5 is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Core.so.5(Qt_5) is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Core.so.5(Qt_5.7) is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Gui.so.5 is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Gui.so.5(Qt_5) is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Widgets.so.5 is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5Widgets.so.5(Qt_5) is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5X11Extras.so.5 is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libQt5X11Extras.so.5(Qt_5) is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686

libxcb-keysyms.so.1 is needed by kf5-kwindowsystem-5.27.0-1.fc25.i686
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-03-03 08:30:22 -0500

Seen: 338 times

Last updated: Mar 04 '17