Ask Your Question
0

Why is plymouth unable to see my nvidia card during boot?

asked 2012-03-01 18:09:06 -0500

kirkb gravatar image

I am trying to change the theme used by plymouth on my fresh-installed, nvidia-carded F16 install. Through appending plymouth:debug I can see that it fails to open the dri render, tried the framebuffer one, notices that the x11 one is not available either, so falls back to the text mode one.

[ply-renderer.c] plyrendereropenplugin:trying to open renderer plugin /usr/lib64/plymouth/renderers/drm.so
[./plugin.c] create
backend:creating renderer backend for device /dev/dri/card0
[./plugin.c] loaddriver:Attempting to load driver '(null)'
[./plugin.c] load
driver:drmOpen failed
[ply-renderer.c] plyrendereropen_plugin:could not open rendering device for plugin /usr/lib64/plymouth/renderers/drm.so

Sure enough I don't have a /dev/dri folder at all once I'm finished booting.

My research so far has found this message on the Plymouth mailing list where it is stated that I have to ensure my kernel modesetting driver is loaded. That doesn't make much sense to me.

I found this Fedora wiki document helped me understand this a bit more. Looking in my grub2.cfg I found that the option they mention is, in fact, disabled. So I tried re-enabling it, but this had no effect. I still had the same problem in my plymouth log.

This may be because I'm using the nvidia rpmfusion driver? I don't know.

So does FC16 have this disabled by default for some reason? Have I lost the ability to have a graphic boot splash by installing the nvidia drivers? Is there any way to continue to investigate this issue?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-03-01 22:57:30 -0500

kirkb gravatar image

Additional research has uncovered the fact that using the nvidia proprietary drivers means plymouth will break in FC16 - grub2 doesn't support the old 'vga' option used to enable graphic plymouth themes.

This blog post was very helpful, and rose above the sea of other "scripts" and "recommendations" out there (most for Ubuntu which may or may not apply to FC).

The blog post walks you through step by step the edits to grub.conf that are needed to enable graphic booting again. It includes an optional step of using a nicer font for grub2 too (bonus!).

I followed the instructions and they solved my problem even via copy/paste.

Now I hope an upgrade to doesn't bork this again in the future - it is nice to finally see plymouth themes.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-01 18:09:06 -0500

Seen: 2,509 times

Last updated: Mar 01 '12