Ask Your Question
0

"Fedora" boot option stuck in BIOS/UEFI

asked 2012-11-08 12:35:38 -0500

SU gravatar image

updated 2012-11-08 12:36:18 -0500

I installed Fedora but the removed it but now it is stuck in the list of boot devices regarding the motherboard boot order. For example I can have first boot device "Fedora" then 2nd boot device cd-dvd dive, then 3rd boot device hard-disk. I have now switched hard disks and the hard disk I am now using has never had Fedora installed on so I cannot understand why Fedora continues to be listed as a boot option.

Just to be absolutely certain there was nothing on my hard-disk causing Fedora to listed in my motherboard boot options I completely removed the hard disk and the computer continues to register Fedora without any hard disk being connected to the computer, so it seems Fedora has written information to my motherboard and I want to remove that entry Fedora has written to my motherboard. Either in my BIOS or UEFI there is some stored Fedora info that I want to delete.

How can I do this. The mboard is a Gigabyte. Let me know if you need any more details.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-12-06 14:32:52 -0500

jwboyer gravatar image

You should be able to do this from the UEFI firmware menus. The specific details on how to manage UEFI boot entries are going to vary between the vendors, so I am unfortunately unable to give you exact instructions.

If you have another version of Linux installed on the machine, you could also use the efibootmgr utility to modify the boot options and remove the Fedora entry.

edit flag offensive delete link more
1

answered 2012-12-07 12:50:34 -0500

pjones gravatar image

On UEFI machines, the boot choices are stored in the system firmware's nonvolatile memory - it's sort of like the CMOS on BIOS, but it's used for other things. So while your disk may no longer have Fedora on it, the system firmware still thinks Fedora is something it can attempt booting. Of course, trying to boot it will fail.

If you can't figure out how to remove this boot option in your system firmware menus, one option is to boot Fedora install media, switch to tty2 (ctrl+alt+f2) for a shell, and run "efibootmgr -v" to see which number is associated with that boot option. It'll look something like:

[root@fenchurch ~]# efibootmgr -v
BootCurrent: 0020
Timeout: 0 seconds
BootOrder: 0018
Boot0018* Fedora    HD(1,800,64000,575a990f-d7c9-4f1f-8b22-9d75e080c633)File(\EFI\fedora\shim.efi)

And 0018 is the number you're looking for. Then, you can run "efibootmgr -b 0018 -B" to remove that boot entry.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-11-08 12:35:38 -0500

Seen: 4,213 times

Last updated: Dec 07 '12