Ask Your Question
0

mod_dav_svn error while installing

asked 2012-10-15 02:21:43 -0500

somepalli gravatar image

I am trying to install the svn module but i am getting following error. I have setup my own repository. Please Help me regarding this

Loaded plugins: langpacks, presto, refresh-packagekit Resolving Dependencies --> Running transaction check ---> Package moddavsvn.i686 0:1.7.4-6.fc17 will be installed --> Processing Dependency: httpd-mmn = 20051115-x86-32 for package: moddavsvn-1.7.4-6.fc17.i686 --> Processing Dependency: subversion-libs(x86-32) = 1.7.4-6.fc17 for package: moddavsvn-1.7.4-6.fc17.i686 --> Finished Dependency Resolution Error: Package: moddavsvn-1.7.4-6.fc17.i686 (fls) Requires: httpd-mmn = 20051115-x86-32 Installed: httpd-2.2.22-4.fc17.i686 (@UIedited0) httpd-mmn = 20051115 httpd-mmn = 20051115-x86-32 Error: Package: moddav_svn-1.7.4-6.fc17.i686 (fls) Requires: subversion-libs(x86-32) = 1.7.4-6.fc17 Installed: subversion-libs-1.7.5-1.fc17.i686 (installed) subversion-libs(x86-32) = 1.7.5-1.fc17 Available: subversion-libs-1.7.4-6.fc17.i686 (fls) subversion-libs(x86-32) = 1.7.4-6.fc17 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-10-15 03:25:11 -0500

liam gravatar image

First, verify that the version of svn you are trying to install is the one you want (that httpd-mmn package looks old). If these are repos you made yourself, and they are setup correctly, AND the rpms are correct then try the following:

Looks like you're using versions of httpd-mmn and subversion-libs that are too recent for moddavsvn. You can try downgrading those packages specifically using "yum downgrade" but you need to make sure that nothing except moddavsvn is using those packages using "rpm -q --whatrequires". Keep in mind that that last command only gives you the first level of dependencies. That is, if you type in that command with glib2 it only show things that directly require it, not all of the reverse dependencies. Still, it should give you a good idea.

Hope this helps.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-10-15 02:21:43 -0500

Seen: 385 times

Last updated: Oct 15 '12