Ask Your Question
0

How to stop software center from notifying me about nodejs updates?

asked 2017-02-02 04:36:44 -0500

lynob gravatar image

I installed nodejs using dnf on fedora 25, then removed and installed the package from nodejs' website.

I excluded npm from dnf. Dnf stopped notifying me about npm updates but the software center is still notifying me.

Should I exclude npm from yum as well or what? It's annoying.

I already asked on unix.stackexchange And the answer didn't solve the issue so far unfortunately. Maybe I could find some nodejs users here who have solved this issue.

edit retag flag offensive close merge delete

Comments

The problem that packagekit/Software ignore the settings in dnf.conf has been reported here

florian gravatar imageflorian ( 2017-02-02 09:55:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-02 09:52:07 -0500

florian gravatar image

To stop Gnome Software from notifying you about a specific package you need to find out how to tell PackageKit to exclude that package (and not dnf since Gnome Software uses PackageKit as its backend).

Here are two possible workarounds:

Are you using Gnome Software at all? If not, just disable the service by masking the packagekit service.

Or if you are using it (which you should not if you are also using dnf), then completely disable notifications for Gnome Software.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-02-02 04:36:44 -0500

Seen: 97 times

Last updated: Feb 02 '17