Ask Your Question
0

Can't use 2560 x 1080 (21:9) resolution fedora 25

asked 2017-01-30 13:05:06 -0500

ovg gravatar image

I've just installed fedora on my laptop and it won't let me choose a resolution above 1920x1080. I've tried xrandr (using both wayland and xorg) but still can't change it.

All works on windows, using HDMI. Laptop has fedora 25, i7-3632QM, AMD 7730. It also works on Ubuntu automatically.

$ xrandr --newmode "2560x1080_60.00"  230.00  2560 2720 2992 3424  1080 1083 1093 1120 -hsync +vsync
$ xrandr --addmode XWAYLAND1 2560x1080_60.00
$ xrandr --output XWAYLAND1 --mode 2560x1080_60.00

$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 2160, maximum 8192 x 8192
XWAYLAND1 connected 1920x1080+0+1080 340mm x 190mm
   1920x1080     59.96*+
XWAYLAND3 connected 1920x1080+0+0 800mm x 340mm
   1920x1080     59.88*+

I think there might be a detection problem, in the display settings in says ' Goldstar Company Ltd 34" ' but it is an LG 29".

From Xorg.1.log:

intel(0): Not using mode "2560x1080_60.00" (exceeds panel dimensions)
[ 110.333] (II) intel(0): Supported detailed timing: [ 110.333] (II) intel(0): clock: 185.6 MHz Image Size: 798 x 334 mm
[ 110.333] (II) intel(0): h_active: 2560 h_sync: 2624 h_sync_end 2688 h_blank_end 2784 h_border: 0
[ 110.333] (II) intel(0): v_active: 1080 v_sync: 1083 v_sync_end 1093 v_blanking: 1111 v_border: 0

Is the above telling me that the supported resolution is 2560x1080? and that it is also exceeding panel dimensions??

Is it possible that this is a graphics driver problem?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2017-01-30 14:37:56 -0500

I have a similar problem with a samsung 24' inch, have you checked if the EDID of the device is there?

It should be located here

/sys/devices/pci0000\:00/0000\:00\:02.0/drm/card0/card0-HDMI-A-1/edid

If the specification is missing or is wrong than I think the only solution is to wait for it to come out or report it. It may also be a mismatch between the EDID and graphics driver see for example:

https://software.intel.com/en-us/arti...

in that case look for AMD proprietary drivers on RPM-fusion repos.

edit flag offensive delete link more

Comments

Using monitor-parse-edid: http://pastebin.com/a3NayCvB

It is detecting the LG ultrawide (although it thinks I have the 34 inch) Why is there a preferred modeline? What does the supported modeline refer to? (limited support by what? HDMI or fedora?)

ovg gravatar imageovg ( 2017-01-30 16:33:17 -0500 )edit

This looks promising. You should add the first Modeline using xrandr

xrandr --newmode "2560x1080" 185.58 2560 2624 2688 2784 1080 1083 1093 1111 -hsync -vsync xrandr --addmode HDMI1 2560x1080 xrandr --output HDMI1 --mode 2560x1080

It should work.

necromandos gravatar imagenecromandos ( 2017-01-31 01:38:05 -0500 )edit

That's what I tried. But the screen doesn't even blink like when changing other resolutions. It seems to add the entry to the GUI display settings but same thing nothing happens. Any idea why it would say preferred and supported? Thanks :)

ovg gravatar imageovg ( 2017-01-31 05:03:52 -0500 )edit

You can also use the Xorg server instead of WAYLAND. On the login screen there is a small gear below the password input where you can choose that option. Otherwise I would install Fedora 24 since it is supported by more mature graphics drivers.

necromandos gravatar imagenecromandos ( 2017-01-31 10:47:34 -0500 )edit

I've already tried the xorg option too. It's the same result. Is this a problem with my amd driver or the intel drivers?

ovg gravatar imageovg ( 2017-01-31 12:03:15 -0500 )edit
0

answered 2017-10-09 12:37:11 -0500

_taut gravatar image

fedoraproject.org/wiki/Waylandfeatures#XRandRcontrolofWayland_outputs

This says xrandr is read only with XWayland

If you uncomment #WaylandEnable=false in /etc/gdm/custom.conf to disable Wayland then you can use xrandr to change resolution.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2017-01-30 13:05:06 -0500

Seen: 2,534 times

Last updated: Jan 30 '17