Ask Your Question
0

Fedora 17: How can I eliminate "Input Signal Out of Range" messages?

asked 2012-06-09 20:16:30 -0500

RKCole gravatar image

Hello.

I have a HP Pavilion p6607c system which is now running Fedora 17 exclusively. The system has a widescreen LCD monitor which supports up to a 1600x900 screen resolution at a refresh rate of 60 Hz. Whenever I boot this system, or whenever I try to run some applications (such as games for my son), I see a message on-screen which basically states: "Input Signal Out of Range. Adjust your settings to 1600x900 at 60 Hz" (please bear with me as am I somewhat paraphrasing this as I have very poor vision because I am partially blind).

I saw this same issue when I used to run Ubuntu on this same system. Under Ubuntu I was able to solve this issue by changing an entry for "GRUB_GFXMODE" in /etc/default/grub.

I have the proprietary nVidia driver installed on this machine for the integrated nVidia GeForce 6150SE, nForce 430 VGA graphics card. Even before the installatin of the nVidia driver, this issue still occurred using the Nouveau driver.

In case it would be of any assistance, here are the contents of my /etc/X11/xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.53  (mockbuild@builder1.ovh.rpmfusion.lan)  Tue 
# May 22 21:10:13 CEST 2012

# RPM Fusion - nvidia-xorg.conf
# 

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/keyboard"
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbLayout" "us"
    Option         "XkbModel" "pc105"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "HP 2010"
    HorizSync       24.0 - 83.0
    VertRefresh     50.0 - 76.0
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6150SE nForce 430"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Videocard0"
    Monitor        "Monitor0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1600x900_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I have searched for a resolution to this issue, but almost all postings which I have found were for Fedora 12 and earlier.

thanks for any input which you can provide.

Take care.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-06-15 15:38:57 -0500

For the GRUB_GFXMODE setting, try adding this line to /etc/default/grub

GRUB_GFXMODE=1024x768

then rebuild your grub.cfg file by

grub2-mkconfig -o /boot/grub2/grub.cfg

Reference: http://thread.gmane.org/gmane.linux.redhat.fedora.testers/98965/focus=98968

Above might help with set an appropriate video mode during boot. I don't know about the other problem of applications and games switching to an unsupported video mode.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-06-09 20:16:30 -0500

Seen: 4,775 times

Last updated: Jun 15 '12