Ask Your Question
0

Limited monitor resolution in fedora 17.

asked 2012-05-29 14:29:37 -0500

tillodoc gravatar image

updated 2014-09-28 08:47:45 -0500

mether gravatar image

I have a full HD screen, but Fedora just shows a lower resolution, Why?

Fedora 17, 64bit, KDE. Please help me! thank you.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-09-05 19:35:16 -0500

Citivolus gravatar image

A possibility is that you are attempting to exceed the bandwidth supported by your video cable. For example, standard HDMI will only go up to 1920x1080, so you still need "High Speed HDMI" or "dual link DVI" to go up to 2560x1600.

edit flag offensive delete link more
0

answered 2012-10-13 04:54:02 -0500

I've got an old Magnavox 2004 20MF200V/17. I was ready to toss it and get a newer one but thought I might give it a last shot. I wanted 1280x1024 but no could do.

On Windows XP, it seems to have no problem giving me a higher resolution above 1024x768 but on both Fedora and Ubuntu no go, did not even see that resolution. I've got an NVidia GEForce 7000 series 620i so I downloaded the proprietary driver and dropped to run level 3 from a root prompt in terminal by typing init 3 (to shut off X windows) and then logged in as root and did a ./nameofdriver and it ran. (Of course I had already marked it as executable by right clicking and checking "allow to run as program" earlier, otherwise it just sits there). Driver installed fine, but STILL no higher resolution.

Then I tried some xrandr fun. Works for many but did not work here, UNTIL I found the "magic" command at the end. Here's the sequence.

I tried for the 1366x768.

gtf 1366x768 This returns 1368x768 and then a bunch of numbers...plug that into the next command:

xrandr --newmode "1368x768_60" (bunch of numbers from previous command) -Hsync -Vsync

Now do xrandr --addmode VGA (or whatever your screen symbolic name is, it might be VGA-1 or whatever) 1368x768_60.00

now type xrandr --output VGA 1368x768_60.00

That should do it BUT OF COURSE FOR ME IT DIDN'T... NO change at all. I got errors back from typing some of these things, errors like "BAD MATCH" or whatever. Worthless for figuring out what's wrong. Anyway, after some hours of searching, I tried one last desperate thing, by now typing

xrandr --output VGA --scale 1.5x1.5

It worked immediately and I got the desired higher resolution. I suspect if I go back now and retry the 1280x1024 it will work but I'm happy with 1368x768 for now. The 1280x1024 may be too high for my Magnavox or it may just need that --scale trick, I'll experiment later. But it was thanks to --scale that I FINALLY got it to work. My thanks to the one person who posted about that which gave me the idea. I've looked at 30, 40, maybe 50 web sites and never saw mention of --scale until I found that one post.

Side thought: Linux has had this type of problem from day one. The "advantage" over Windoze and Mac operating systems is shrinking or non-existent. I was seriously thinking about buying Windows 7 until I finally got this working. The hobbyist era is OVER for Linux. Get professional or get out of the way. People do NOT have time to muck around with this nonsense anymore.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-05-29 14:29:37 -0500

Seen: 3,624 times

Last updated: Oct 13 '12