Ask Your Question
1

Any tips troubleshooting wifi issues with Realtek and latest fedora25 kernels?

asked 2017-01-24 08:49:24 -0500

wjyoung gravatar image

updated 2017-01-25 07:31:18 -0500

After the last couple of kernel updates obtained through Software Install, wifi on my laptop has stopped working. I didn't notice immediately because I've had the laptop at my desk connected to an ethernet cable. But yesterday I tried working elsewhere and noticed I couldn't connect using wifi.

The symptoms are:

Wifi sometimes appears to be connected after boot up (little wifi signal icon in the top right hand corner of the Gnome GUI looks normal). But I cannot ping anything on my local network, and nslookup fails.

Sometimes, after a restart, the Wifi icon is replaced by a question mark.

It doesn't work with my guest network either.

Rebooted into an older kernel, and wifi worked fine.

Modules probably related to wifi:

rtl8192ce, rtl8192c_common, rtlwifi

(i.e. Realtek) Bad kernel(s) obtained through Software Install updates: 4.9.5-200.fc25.x8664 and 4.9.4--201.fc25.x8664 Last good kernel on my system: 4.8.15-300.fc25.x86_64

I'm not sure if it's the kernel or if it's the modules. I'm just saying "bad kernel" or "good kernel" because those are the kernel versions in grub that I boot into.

Not sure if this is relevant, but here is the output of route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlp3s0
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp3s0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

I noticed someone else posted a problem with their Realtek wifi a few days ago, too. Is there anything else I can try to get to the bottom of this? It's been awhile since I've recompiled a kernel, but I'm not adverse to trying it out if there is some indication this is a known issue that may have been fixed.

Thanks in advance!

Update

Thanks for the suggestions. Power down doesn't work any better, unfortunately. Tried it a few times. Once, I got a console open and was able to ping my router, but ping stopped working after a few seconds. Other times, power down just doesn't help at all.

As an aside, power down takes over 5 minutes when the network is not working. It's like fedora is trying to "phone home" one last time. Of course wifi is not working properly, so it times out eventually.

edit retag flag offensive close merge delete

Comments

Just to add to this: I have the same problem with FC24 but when I reboot and select kernel 4.8.16-200 Wifi works fine.

CWu gravatar imageCWu ( 2017-01-24 10:01:02 -0500 )edit

Is it because it "senses" it is in airplane mode? I never got wifi to work with F25, even after two months of trying everything.

wallyk gravatar imagewallyk ( 2017-01-24 10:19:03 -0500 )edit

I completely powered down my laptop then powered up and now the WiFi is working. Give that a try?

CWu gravatar imageCWu ( 2017-01-24 12:01:38 -0500 )edit

What is the output of lspci | grep -i wire? It's not an "airplane mode" issue because you do get an IP address. For now, make sure you are running the "good" kernel when you do updates, so that dnf doesn't remove it.

ssieb gravatar imagessieb ( 2017-01-24 14:11:15 -0500 )edit

I have the same problem with the 4.9.x kernels on my Fedora 24 machine using the RTL8188CE chip.

BTW: the command of @Samuel_Sieb above needs to be adjusted: lspci | grep -i Wi:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
florian gravatar imageflorian ( 2017-01-25 09:13:15 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2017-02-02 22:53:30 -0500

florian gravatar image

Here is a workaround for this problem until the issue gets fixed upstream: https://bugzilla.redhat.com/show_bug....

cat /etc/modprobe.d/rtl8192ce.conf

#Disable powersaving
options rtl8192ce ips=0

# WARNING! Do not enable this shit.
#          It causes bugs.
options rtl8192ce fwlps=0

# Use software control instead
# options rtl8192ce swlps=1
edit flag offensive delete link more

Comments

Can confirm this worked for me.

wjyoung gravatar imagewjyoung ( 2017-02-03 06:26:51 -0500 )edit
1

answered 2017-01-25 23:27:06 -0500

florian gravatar image

This is a kernel bug (kernel-4.9.x) for both F24 and F25 that has been reported here: https://bugzilla.redhat.com/show_bug....

Feel free to subscribe to the bug report in order to receive updates and workarounds.

edit flag offensive delete link more
0

answered 2017-01-24 09:38:21 -0500

me too, I have the same problems, when i use dnf update to the new kernel, but it cannot restart properly,

then i press reset button to restart my computer, then same, i take out my realtit seens no effects inside, Realtek 10/100Mbps PCI Lan card, then it ccould restart poperly, i suggest that you could remove the wifi device, then you can solve the problems and reset.

edit flag offensive delete link more

Comments

Speaking for myself, it's kinda hard to remove WiFi device on a laptop. That also doesn't solve the real issue of connecting with WiFi, which is what was asked, rather than trouble starting FC25.

CWu gravatar imageCWu ( 2017-01-24 11:20:20 -0500 )edit

Question Tools

3 followers

Stats

Asked: 2017-01-24 08:49:24 -0500

Seen: 1,395 times

Last updated: Feb 02 '17