Ask Your Question
0

vsftpd systemctl and passwords

asked 2012-03-11 17:12:13 -0500

DavidCasper gravatar image

updated 2012-03-11 17:14:51 -0500

I had a really difficult time installing vsftpd in fedora 16 despite the helpful messages and the bug reports on it. It would be nice for someone to write a summary of what it takes to really install this clean today, or describe the workarounds. Now I do seem to have it running, but all client logins fail with '530 Login incorrect'. I presume this is the password, but I guess it could be the user name. How do I fix this please? I figure it should just be simple.

Some background: First, I do have the following in vsftpd.conf

local_enable=YES

Secondly, I always seem to have two entries in systemctl and I think I should only have one. Also one seems active and the other failed. But sometimes it is the second that is failed and sometimes the first. But I can't seem to clean this up. This may be the root of my problems (I said the vsftpd install was very difficult).

[root@exeter david]# systemctl | grep ftp
vsftpd.service            loaded failed failed        Vsftpd ftp daemon
vsftpd@multi-user.service loaded active running       Vsftpd ftp daemon

Any help would be most appreciated
David

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-03-11 19:48:52 -0500

DavidCasper gravatar image

OK. I fixed this. I used yum to clean vsftpd and use systemctrl to remove all signs of vsftpd and rebooted.

Then I did as follows:

  • In directory /lib/systemd/system copied vsftpd.service to vsftpd@.service
  • systemctl enable vsftpd@.service
  • systemctl start vsftpd.service>
  • Finally edited /etc/shells to add /bin/bash - which fixed the user/poassword problem

I really cant understand why they make new versions of Fedora if they introduce nonesense such as this.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2012-03-11 17:12:13 -0500

Seen: 1,113 times

Last updated: Mar 11 '12