Ask Your Question

how to add custom resolution in fedora 25 ?

asked 2017-01-18 08:46:04 -0500

akkk33 gravatar image

Hello , I'm new to the Fedora world , came from Ubuntu. Now my monitor is 1440x900 resolution (I'm sure about that). After setting up Fedora by following official documentations in , I realized that the resolution is 1280x1024 and there's no other option for 1440x900 !!!! So I searched for a solution and followed it here -> But the result was bad , after restarting , the screen was flashing rapidly with no input response ! My PC info : HP dc-7900 , Intel integrated Q45 Fedora 25 OS . Any solution ??

edit retag flag offensive close merge delete


Welcome to ask.fedora. 1440x900 sounds like a rather strange resolution; do you know what your aspect ratio is? Please run xrandr in a terminal and report the output in a comment. Speaking from recent experience, if your system isn't detecting a mode, it won't let you set it. (In my case, I suspect the graphics card, but let's not be hasty here.)

sideburns gravatar imagesideburns ( 2017-01-18 11:11:44 -0500 )edit

hi sideburns , I typed xrandr in the Terminal and this is the result :

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected primary 1280x1024+0+0 0mm x 0mm
   1280x1024      0.00* 
   1024x768       0.00  
   800x600        0.00  
   640x480        0.00

Please note that in the past , Ubuntu was showing this resolution normally ,,,, I have tried many other debian-based distros like linux mint and tails , and There was no problem with the display .

akkk33 gravatar imageakkk33 ( 2017-01-18 17:40:49 -0500 )edit

Did you install from a LiveUSB? If so, boot from that and see if it detects your resolution correctly. I'm not sure where to go from there, but I am sure that somebody here knows.

sideburns gravatar imagesideburns ( 2017-01-18 18:41:32 -0500 )edit

the liveUSB doesn't show the correct resolution either !!

akkk33 gravatar imageakkk33 ( 2017-01-18 19:44:33 -0500 )edit

Can you either hook this monitor up to a different computer, or a different monitor on this one?

sideburns gravatar imagesideburns ( 2017-01-19 01:26:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-05-01 13:21:51 -0500

savcom gravatar image

Hi, I had the same issue :) I disabled the wayland mode by editing the custom.conf file located in etc/gdm. Reboot and proceed with xrandr.

I hope it's helpful. Bye.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2017-01-18 08:46:04 -0500

Seen: 1,555 times

Last updated: Jan 18 '17