Tips on reducing disk I/O?

asked 2017-01-12 11:05:15 -0500

updated 2017-01-12 12:36:25 -0500

My installation of Fedora 25 with KDE is having some unnerving issues with disk I/O. It's constant and for some applications (like Firefox and Lollypop, just to name a couple) it sometimes does a huge disk access.

I've done the "usual":

  1. Disabled baloo;
  2. Edited /etc/fstab and put noatime at both root and home (since access time is not a priority for me);
  3. Disabled every automatic indexing present on System Settings (as far as I can tell)

And yet jdb keeps showing up on iotop in ≃10-15s intervals...

Should I put a high "commit" interval at /etc/fstab as well? I mean, since it's a notebook I don't have issues with power failure...

What else can be done? What am I missing?

TIA,

edit retag flag offensive close merge delete

Comments

1

Does Fedora recognize and use the entire RAM properly? Can you replace the HDD with an SSD? The computer will run way way faster and SSDs are pretty inexpensive lately.

wallyk gravatar imagewallyk ( 2017-01-12 13:32:29 -0500 )edit

Thank you for your answer. How can I check if all the RAM is being recognized? As of SSD, sure, I plan to use it, but that's a different subject.

galvao gravatar imagegalvao ( 2017-01-13 02:53:23 -0500 )edit
1

@galvao: In the GUI, run the details applet. The second items is "Memory". From a terminal, run the top command. The 4th line says something like KiB Mem : 4037464 total, 1388032 free, 1398668 used on my 4 GB machine.

wallyk gravatar imagewallyk ( 2017-01-20 15:34:34 -0500 )edit