Ask Your Question

Revision history [back]

Thanks for the pointers, you saved my life! For the records, here is what I did:

  • I ran lsblk -f, which gave me the UUID of the "masked" partition: by the way, I'd love to understand how this command works: I was under the impression that the partition table of my sda5 drive was incomplete, yet lsblk was able to list all partitions attached to this drive, including the masked g_chaplin-lv_home. Flabbergasting :-)

  • I created a /media/home directory: sudo mkdir /media/home

  • I added a new line to /etc/fstab:

    UUID=my_uuid /media/home ext4 ro,suid,dev,exec,auto,nouser,async 1 2

(surely you can just use "defaults" for the option field, but I was not in the mood of taking more risks, and I wanted to mount the partition "ro" first)

  • then I actually mounted the partition: sudo mount -a
  • at this stage, cd /media/home, take a big breath, and yes, everything is there!
  • I rebooted, at the grub splash screen, I modified the command to boot into runlevel 3. This is done by typing the key e to edit the desired line, turning it into something like:

    linux16 /vmlinuz-4.2.3-300.fc23.x86_64 root=/dev/mapper/vg_chaplin-lv_root ro rd.lvm.lv=vg_chaplin/lv_root rd.lvm.lv=vg_chaplin/lv_swap 3 LANG=en_US.UTF-8

(the important bit is the digit 3 around the end)

  • I ran fedora using the above command line, and logged in as root (so that I would not need the /home directory)
  • backed up /home with mv /home /old_home for extra care

  • modified /etc/fstab again with the final line:

    UUID=my_uuid /home ext4 defaults 1 2

  • and rebooted to finally return to a pristine system!