Ask Your Question

Revision history [back]

I also had this problem. Short answer is I fixed it by reinstalling grub2, I had to do 2 steps:

  1. sudo yum install grub2-efi-modules
  2. sudo grub2-install /dev/sda

Long answer: I installed Fedora 23 from a DVD. Since I only had the one HDD and the one DVD drive, I thought the error might be from GRUB trying to read my empty DVD drive. When I ran 'ls' from the GRUB command prompt it gave the error about failing to read from sector 0x0 on hd1, hd0 properly showed the partitions on my HDD.

I rebooted the machine with a DVD in the drive and ran another 'ls' from the GRUB command prompt, now instead of giving the error, it listed partitions for cd0. Booting into Fedora 23 from GRUB normally no longer gave the error.

I also noticed a second problem, changes to /etc/default/grub were not showing up in GRUB after running 'sudo grub2-mkconfig -o /dev/grub2/grub.cfg'. The combination of these two issues made me thing GRUB wasn't installed correctly. This wasn't too surprising as I had another linux distro installed on the drive previously.

After installing grub2-efi-modules (needed if you get an error about a missing file) and running grub2-install it boots without the error and changes to /etc/default/grub are showing up.