Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I had the same problem with my Intel NUC, dual boot F20 and Windows 7.
I did some research and the problem seems to be related to the interaction between BIOS and Linux.

Some people solved it updating to the last BIOS version, see for instance this forum:
https://communities.intel.com/thread/47751?start=105&tstart=0.
In my case the latest BIOS (which solved the problem for the Intel NUC) was still a beta and I did not want to run the risk.

I also found this other post related to the same problem with Ubuntu:
http://askubuntu.com/questions/132143/stuck-on-reboot-and-shutdown/135568#135568

They were proposing to add "acpi=noirq" at the end of line GRUB_CMDLINE_LINUX_DEFAULT in the grub file

sudo gedit /etc/default/grub

set

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

then

sudo update-grub

For many people this seems to have solved the problem. I read acpi=noirq suffices for standard booting, which simply doesn't use ACPI for irq routing, I was not sure if it could have side effects and I did not try it.

Still from the first Intel forum, I found another solution: they suggested to change BIOS parameters to enable "Deep S4/S5" (deeper sleep) and to disable "Wake on LAN" (WOL allows you to boot your computer using an ethernet cable).

I tried it and that solved my problem. Hope it works for you.

Ciao