Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

I re-installed gnome: sudo yum erase @gnome-desktop yum install @gnome-desktop

And since I have NVIDIA card, I had to install its drivers: http://www.if-not-true-then-false.com/2011/fedora-16-nvidia-drivers-install-guide-disable-nouveau-driver/

First I tried akmod-nvidia drivers, which didn't work. Later I installed akmod-nvidia drivers. This apparently resolved the issue.

But now I am getting a screen freeze with following in the /var/log/messages:

Dec 19 17:50:34 color dbus-daemon[1008]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Dec 19 17:50:34 color dbus-daemon[1008]: ** Message: entering main loop
Dec 19 17:50:34 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=IsInhibited
Dec 19 17:50:34 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=IsInhibited
Dec 19 17:50:35 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Dec 19 17:50:35 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Dec 19 17:50:37 color kernel: [   62.460527] NVRM: Xid (0000:02:00): 6, PE0003 
Dec 19 17:50:37 color kernel: [   62.463267] NVRM: Xid (0000:02:00): 6, PE0003 0970 00000000 00000000 00000000 00000000
Dec 19 17:50:37 color kernel: [   62.465766] NVRM: Xid (0000:02:00): 6, PE0002 
Dec 19 17:50:37 color kernel: [   62.515610] NVRM: Xid (0000:02:00): 26, Ch 0000007f M 00000970 D 00000000 intr 04400000
Dec 19 17:50:37 color kernel: [   62.518719] NVRM: Xid (0000:02:00): 26, Ch 0000007f M 00000930 D 20000020 intr 04400010
Dec 19 17:50:37 color kernel: [   62.524221] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000970 D 00000000 intr 00400000
Dec 19 17:50:37 color kernel: [   62.526164] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000930 D 20000020 intr 00400010
Dec 19 17:50:37 color kernel: [   62.531573] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000970 D 00000000 intr 04400000
Dec 19 17:51:03 color kernel: [   88.208050] BUG: soft lockup - CPU#0 stuck for 23s! [gnome-shell:1607]
Dec 19 17:51:03 color kernel: [   88.208054] Modules linked in: lockd bridge stp llc snd_hda_codec_analog joydev snd_hda_intel nvidia(P) snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc snd_pcm snd_timer snd i2c_i801 i2c_core dcdbas serio_raw iTCO_wdt iTCO_vendor_support tg3 microcode soundcore snd_page:debug2: channel 0: window 999251 sent adjust 49325
_alloc i7core_edac edac_core ppdev parport_pc dell_wmi sparse_keymap parport sunrpc virtio_net kvm_intel kvm uinput usb_storage wmi [last unloaded: scsi_wait_scan]
Dec 19 17:51:03 color kernel: [   88.208089] CPU 0 
Dec 19 17:51:03 color kernel: [   88.208090] Modules linked in: lockd bridge stp llc snd_hda_codec_analog joydev snd_hda_intel nvidia(P) snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc snd_pcm snd_timer snd i2c_i801 i2c_core dcdbas serio_raw iTCO_wdt iTCO_vendor_support tg3 microcode soundcore snd_page_alloc i7core_edac edac_core ppdev parport_pc dell_wmi sparse_keymap parport sunrpc virtio_net kvm_intel kvm uinput usb_storage wmi [last unloaded: scsi_wait_scan]
Dec 19 17:51:03 color kernel: [   88.208112] 
Dec 19 17:51:03 color kernel: [   88.208114] Pid: 1607, comm: gnome-shell Tainted: P            3.1.5-6.fc16.x86_64 #1 Dell Inc. Precision WorkStation T3500  /0XPDFK
Dec 19 17:51:03 color kernel: [   88.208117] RIP: 0010:[<ffffffffa08fd1af>]  [<ffffffffa0..]

I found that this bug is observed in Ubuntu as well and is still not resolved there also: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/893431

I re-installed gnome:

sudo yum erase @gnome-desktop
yum install @gnome-desktop

@gnome-desktop

And since I have NVIDIA card, I had to install its drivers: http://www.if-not-true-then-false.com/2011/fedora-16-nvidia-drivers-install-guide-disable-nouveau-driver/

First I tried akmod-nvidia drivers, which didn't work. Later I installed akmod-nvidia drivers. This apparently resolved the issue.

But now I am getting a screen freeze with following in the /var/log/messages:

Dec 19 17:50:34 color dbus-daemon[1008]: ** Message: D-Bus service launched with name: net.reactivated.Fprint
Dec 19 17:50:34 color dbus-daemon[1008]: ** Message: entering main loop
Dec 19 17:50:34 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=IsInhibited
Dec 19 17:50:34 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/gnome/SessionManager interface=org.gnome.SessionManager method=IsInhibited
Dec 19 17:50:35 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Dec 19 17:50:35 color gnome-session[1538]: DEBUG(+): GsmDBusClient: obj_path=/org/freedesktop/DBus interface=org.freedesktop.DBus method=NameOwnerChanged
Dec 19 17:50:37 color kernel: [   62.460527] NVRM: Xid (0000:02:00): 6, PE0003 
Dec 19 17:50:37 color kernel: [   62.463267] NVRM: Xid (0000:02:00): 6, PE0003 0970 00000000 00000000 00000000 00000000
Dec 19 17:50:37 color kernel: [   62.465766] NVRM: Xid (0000:02:00): 6, PE0002 
Dec 19 17:50:37 color kernel: [   62.515610] NVRM: Xid (0000:02:00): 26, Ch 0000007f M 00000970 D 00000000 intr 04400000
Dec 19 17:50:37 color kernel: [   62.518719] NVRM: Xid (0000:02:00): 26, Ch 0000007f M 00000930 D 20000020 intr 04400010
Dec 19 17:50:37 color kernel: [   62.524221] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000970 D 00000000 intr 00400000
Dec 19 17:50:37 color kernel: [   62.526164] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000930 D 20000020 intr 00400010
Dec 19 17:50:37 color kernel: [   62.531573] NVRM: Xid (0000:02:00): 26, Ch 00000000 M 00000970 D 00000000 intr 04400000
Dec 19 17:51:03 color kernel: [   88.208050] BUG: soft lockup - CPU#0 stuck for 23s! [gnome-shell:1607]
Dec 19 17:51:03 color kernel: [   88.208054] Modules linked in: lockd bridge stp llc snd_hda_codec_analog joydev snd_hda_intel nvidia(P) snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc snd_pcm snd_timer snd i2c_i801 i2c_core dcdbas serio_raw iTCO_wdt iTCO_vendor_support tg3 microcode soundcore snd_page:debug2: channel 0: window 999251 sent adjust 49325
_alloc i7core_edac edac_core ppdev parport_pc dell_wmi sparse_keymap parport sunrpc virtio_net kvm_intel kvm uinput usb_storage wmi [last unloaded: scsi_wait_scan]
Dec 19 17:51:03 color kernel: [   88.208089] CPU 0 
Dec 19 17:51:03 color kernel: [   88.208090] Modules linked in: lockd bridge stp llc snd_hda_codec_analog joydev snd_hda_intel nvidia(P) snd_hda_codec snd_hwdep snd_seq snd_seq_device binfmt_misc snd_pcm snd_timer snd i2c_i801 i2c_core dcdbas serio_raw iTCO_wdt iTCO_vendor_support tg3 microcode soundcore snd_page_alloc i7core_edac edac_core ppdev parport_pc dell_wmi sparse_keymap parport sunrpc virtio_net kvm_intel kvm uinput usb_storage wmi [last unloaded: scsi_wait_scan]
Dec 19 17:51:03 color kernel: [   88.208112] 
Dec 19 17:51:03 color kernel: [   88.208114] Pid: 1607, comm: gnome-shell Tainted: P            3.1.5-6.fc16.x86_64 #1 Dell Inc. Precision WorkStation T3500  /0XPDFK
Dec 19 17:51:03 color kernel: [   88.208117] RIP: 0010:[<ffffffffa08fd1af>]  [<ffffffffa0..]

I found that this bug is observed in Ubuntu as well and is still not resolved there also: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/893431