Ask Your Question

urshankar's profile - activity

2017-09-27 07:47:06 -0600 asked a question should subpackages have 'runtime' dependancy matching with toplevel package's 'runtime' dependancies?

For example,

If the top level package's spec file has a subpackage ,

-begin- . .

%package -n toplevel . Requires xyz >= 1.2.3 . .

%package subpackage . . Requires xyz . .

-end-

should xyz be >= 1.2.3 as per the top level constraint for the dependant package xyz ??

the runtime dependancies are captured using 'requires' statement..