Ask Your Question

paulhr's profile - activity

2018-12-11 22:48:22 -0600 received badge  Famous Question (source)
2018-10-24 18:21:54 -0600 received badge  Notable Question (source)
2018-08-02 06:13:35 -0600 received badge  Popular Question (source)
2018-05-03 10:38:33 -0600 received badge  Good Question (source)
2018-05-03 03:56:17 -0600 received badge  Nice Question (source)
2018-05-03 03:56:09 -0600 received badge  Popular Question (source)
2017-05-29 18:24:11 -0600 received badge  Notable Question (source)
2017-05-29 18:24:11 -0600 received badge  Popular Question (source)
2017-03-09 08:04:57 -0600 received badge  Popular Question (source)
2016-10-15 10:57:01 -0600 commented answer recalculate screen size command

You mention typed characters and pressing enter so I am going to assume you want a terminal window to be "recalculated".
Correct.

reset and reset -w have no effect.

2016-10-12 16:22:28 -0600 asked a question recalculate screen size command

I have a Fedora 23 server connected through a Keyborard, Video, Monitor (KVM) switch. Every once a in while the Fedora 23 OS thinks the monitor has more visible lines then actually render on the screen. Which then causes all typed characters to not appear on the screen. But if you press enter enough times the line type scrolls up from the bottom. The only fix I have found is to reboot the server.

Is there a command that will force Fedora to recalculate the screen size?

2016-08-10 07:23:38 -0600 commented answer current best practice to run a script runs at Fedora 23 startup.
2016-08-04 16:06:45 -0600 answered a question Can't locate JSON/RPC/Legacy/Server/CGI.pm in @INC

The correct answer came from Emmanuel Seyman on the RedHat issue tracking system. I am posting it here for the benefit of others.

you need to install perl-JSON-RPC-CGI.

That fixed it.

2016-08-02 09:58:41 -0600 commented question Can't locate JSON/RPC/Legacy/Server/CGI.pm in @INC

Is the question not clear? Or is more detail needed? Why is "apachectl configtest" failing looking for the Legacy RPC when clearly the new JSON-RPC v1.06 was found the bugzilla check?

2016-07-31 17:46:23 -0600 asked a question Can't locate JSON/RPC/Legacy/Server/CGI.pm in @INC

As per my search this issue was solved in Fedora ~17. I am on Fedora 23.

Fedora 23
Bugzilla 4.4.12-1.fc23 (installed via dnf)

============= /usr/share/bugzilla/checksetup.pl --check-modules =============

/usr/share/bugzilla/checksetup.pl --check-modules
* This is Bugzilla 4.4.12 on perl 5.22.1
* Running on Linux 4.4.7-300.fc23.x86_64 #1 SMP Wed Apr 13 02:52:52 UTC 2016

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v4.21 
Checking for           Digest-SHA (any)       ok: found v5.95 
Checking for             TimeDate (v2.23)     ok: found v2.24 
Checking for             DateTime (v0.28)     ok: found v1.18 
Checking for    DateTime-TimeZone (v0.71)     ok: found v1.93 
Checking for                  DBI (v1.614)    ok: found v1.633 
Checking for     Template-Toolkit (v2.22)     ok: found v2.26 
Checking for           Email-Send (v2.04)     ok: found v2.201 
Checking for           Email-MIME (v1.904)    ok: found v1.934 
Checking for                  URI (v1.37)     ok: found v1.69 
Checking for       List-MoreUtils (v0.32)     ok: found v0.413 
Checking for    Math-Random-ISAAC (v1.0.1)    ok: found v1.004 

Checking available perl DBD modules...
Checking for           DBD-SQLite (v1.29)     ok: found v1.48 
Checking for           DBD-Oracle (v1.19)     not found 
Checking for            DBD-mysql (v4.001)    ok: found v4.033 
Checking for               DBD-Pg (v2.7.0)    ok: found v3.5.3 

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.56 
Checking for                Chart (v2.1.0)    ok: found v2.4.10 
Checking for          Template-GD (any)       ok: found v1.56 
Checking for           GDTextUtil (any)       ok: found v0.86 
Checking for              GDGraph (any)       ok: found v1.49 
Checking for           MIME-tools (v5.406)    ok: found v5.506 
Checking for          libwww-perl (any)       ok: found v6.15 
Checking for             XML-Twig (any)       ok: found v3.49 
Checking for          PatchReader (v0.9.6)    ok: found v0.9.6 
Checking for            perl-ldap (any)       ok: found v0.65 
Checking for          Authen-SASL (any)       ok: found v2.16 
Checking for         Net-SMTP-SSL (v1.01)     ok: found v1.03 
Checking for           RadiusPerl (any)       ok: found v0.24 
Checking for            SOAP-Lite (v0.712)    ok: found v1.19 
Checking for          XMLRPC-Lite (v0.712)    ok: found v0.717 
Checking for             JSON-RPC (any)       ok: found v1.06 
Checking for              JSON-XS (v2.0)      ok: found v3.01 
Checking for           Test-Taint (any)       ok: found v1.06 
Checking for          HTML-Parser (v3.67)     ok: found v3.71 
Checking for        HTML-Scrubber (any)       ok: found v0.15 
Checking for               Encode (v2.21)     ok: found v2.80 
Checking for        Encode-Detect (any)       ok: found v1.01 
Checking for          Email-Reply (any)       ok: found v1.203 
Checking for HTML-FormatText-WithLinks (v0.13)     ok: found v0.15 
Checking for          TheSchwartz (v1.07)     ok: found v1.12 
Checking for       Daemon-Generic (any)       ok: found v0.84 
Checking for           File-Slurp (v9999.13)  ok: found v9999.19 
Checking for             mod_perl (v1.999022) ok: found v2.000009 
Checking for     Apache-SizeLimit (v0.96)     ok: found v0.97 
Checking for        File-MimeInfo (any)       ok: found v0.27 
Checking for           IO-stringy (any)       ok: found v2.111 
Checking for          mod_expires (any)       ok 
Checking for ...
(more)
2016-07-27 10:02:16 -0600 commented answer Add a group to a user from the command line as root.

Thank you.

2016-07-27 09:40:11 -0600 asked a question Add a group to a user from the command line as root.

I am using Fedora server, not workstation. As root I want to add the group "agroup" to the user "buser". When I use the usermod command as below it does not work. I just get the help text.

moduser -a agroup buser

2016-07-27 07:57:13 -0600 asked a question What security contexts need to change to allow phpBB to write to directories.

I am trying to install phpBB 3.1.9 on Fedora 23 with the current php runtime installed by dnf.

There is a preInstall check that phpBB does that makes sure phpBB can write to certain directories and update certain files.

phpBB must be able to write to the below directories. /var/www/html/usque/bb /var/www/html/usque/bb/files /var/www/html/usque/bb/cache /var/www/html/usque/bb/store /var/www/html/usque/bb/store/images/avatars/upload All users can write to these directories because that have the drwxrwxrwx but the preinstall test still says it can not write to the directories. The idea was brought up that it may be a SELinux security contexts issue. I have never even heard of the SELinux security context before. After reading up on it I still don't see how to change the setting, or which ones to change.

/var/www/html/usque/bb/files
unconfined_u :object_r :httpd_sys_content_t :s0 index.htm unconfined_u :object_r :httpd_sys_content_t :s0 . unconfined_u :object_r :httpd_sys_content_t :s0 ..

phpBB must be able to update below file. How to change the SELinux security context settings, or which ones to change?

/var/www/html/usque/bb/config.php /var/www/html/usque/bb/phpbb/db/migration/tool/config.php /var/www/html/usque/bb/phpbb/config/config.php /var/www/html/usque/bb/phpbb/di/extension/config.php /var/www/html/usque/bb/phpbb/search/sphinx/config.php

2016-07-27 06:44:02 -0600 received badge  Commentator
2016-07-27 06:44:02 -0600 commented question Is there a forum or bulletin board installable dnf package for Fedora?

I have created a user named phpbb. I added the apache group to phpbb. With no effect. I also checked who else belonged to the apache group. I don't remember creating an apache user or group. I am assuming dnf create the id when httpd was installed. I looked at the /etc/group file. Why does dnf not make the apache group the primary group for the apache user id?

2016-07-26 17:36:56 -0600 asked a question Is there a forum or bulletin board installable dnf package for Fedora?

Is there a forum or bulletin board installable dnf package for Fedora? I have been trying to get phpBB to install. See this thread if you want details. But there is some issue with permissions that I can not get past.

[edit] It is clear the phpBB forum software does not play well with Fredora and SELunix. I am off to find a different forum app.

Thanks for everyones time.

2016-07-21 11:43:26 -0600 commented question Module mod_proxy_balancer is loaded it must be removed in order for mod_proxy_cluster to function properly

Thanks karm. I am creating a Red Hat Bugzilla account now to express my need for a working up to date version of mod_cluster for Fedora 23. The subject matter experts on the tomcat email don't recommend using mod_jk anymore. They commend mod_proxy.

Firstly, you should be using mod_proxy and secondly, TomEE is based on Tomcat, thus the proxy configuration is the same, so Google mod_proxy and Tomcat.

2016-07-20 19:47:38 -0600 asked a question Module mod_proxy_balancer is loaded it must be removed in order for mod_proxy_cluster to function properly

Fedora 23
mod_cluster 1.2.6
httpd-2.4.23-3.fc23.x86_64

I installed mod_cluster with the following comnmands

dnf install mod_cluster  
dnf install mod_cluster-java  
dnf install mod_cluster-javadoc

The instructions on the web site here ( http://docs.jboss.org/mod_cluster/1.3.0 /html/Quick_Start_Guide.html#d0e399) say to copy the follow files.
So I downloaded mod_cluster-parent-1.2.6.Final-bin.tar.gz and mod_cluster-1.2.6.Final-linux2-x64-so.tar.gz. Copied the following files to /opt/tomee/lib

mod_cluster-container-tomcat7-1.2.6.Final.jar
mod_cluster-container-tomcat6-1.2.6.Final.jar
mod_cluster-container-catalina-standalone-1.2.6.Final.jar
mod_cluster-container-catalina-1.2.6.Final.jar
mod_cluster-core-1.2.6.Final.jar
jboss-logging.jar
mod_cluster-container-spi-1.2.6.Final.jar

I getting the following error during httpd start.

[Wed Jul 20 19:41:54.370093 2016] [core:notice] [pid 22671] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Wed Jul 20 19:41:54.373101 2016] [suexec:notice] [pid 22671] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Jul 20 19:41:54.373171 2016] [:warn] [pid 22671] httpd version 2.4.23 mismatch detected
[Wed Jul 20 19:41:54.373188 2016] [:error] [pid 22671] Module mod_proxy_balancer is loaded it must be removed in order for mod_proxy_cluster to function properly
AH00016: Configuration Failed

After removing mod_proxy_cluster.so file from /etc/httpd/modules/ I get the following error.

Jul 20 20:21:44 myServer systemd[1]: Starting The Apache HTTP Server...
Jul 20 20:21:44 myServer httpd[23216]: httpd: Syntax error on line 56 of /etc/httpd/conf/httpd.conf: Syntax error on line 8 of /etc/httpd/conf.modules.d/00-proxy.conf: Cannot load modules/mod_proxy_balancer.so into server: /etc/httpd/modules/mod_proxy_balancer.so: cannot open shared object file: No such file or directory
Jul 20 20:21:44 myServer systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE
Jul 20 20:21:44 myServer systemd[1]: Failed to start The Apache HTTP Server.
Jul 20 20:21:44 myServer systemd[1]: httpd.service: Unit entered failed state.
Jul 20 20:21:44 myServer systemd[1]: httpd.service: Failed with result 'exit-code'.

2016-07-20 14:35:25 -0600 received badge  Supporter (source)
2016-07-20 14:33:48 -0600 commented answer what is the name for the apache mod-jk in dnf?

Based on the description is should be what i need. Just need to figure out how to configure mod_cluster for tomcat 7. More internet searches....

dnf info mod_cluster
. . . Description : ... Like mod_jk and mod_proxy,
: mod_cluster uses a communication channel to forward requests from httpd to one
: of a set of application server nodes. Unlike mod_jk and mod_proxy, mod_cluster
: leverages an additional connection between the application server nodes and
: httpd.
...

2016-07-20 13:10:24 -0600 asked a question what is the name for the apache mod-jk in dnf?

As per this article, I tried

# dnf install libapache2-mod-jk
Last metadata expiration check: 1:56:37 ago on Wed Jul 20 12:05:48 2016.
No package libapache2-mod-jk available.
Error: Unable to find a match.

That did not work.

I did a search of dnf with mod_jk but that came up empty.

# dnf list mod_jk
Last metadata expiration check: 2:02:38 ago on Wed Jul 20 12:05:48 2016.
Error: No matching Packages to list

What is the name of the module so can install it with dnf?

2016-07-13 14:12:12 -0600 asked a question current best practice to run a script runs at Fedora 23 startup.

I have a Fedora 23 server, not workstation. I want the current best practice to run a script that starts my Tomee-Plume server. I can find old forum posts about using the rc.local command. But is that still the best practice for Fedora 23?

I have tried to create my own "systemd unit" file. While there is a "systemd unit" file for Tomcat, there is no "systemd unit" file for Tomee-Plume. Trying to customize the existing Tomcat "systemd unit" file for Tomee-Plume has failed. My skills are not deep enough to figure out why it always locks on exit.

Is the old /etc/rc.d/rc.local command the only option left in my case? Or is there something newer and better?

2016-06-17 11:52:08 -0600 commented answer What is the current entropy generator?

I took your advice and yes just used haveged. At least there's more documentation. It would be nice if there was some way that it would tell you in a log that it was producing stuff. As it stands you just have to trust that system control is telling you that it's running it's working.

Thanks very much. Hope to return the favor someday.

2016-06-17 08:23:21 -0600 commented answer What is the current entropy generator?

This forum and a very short amount of space allowed for comments therefore my prior comment that cut off. This is a continuation of my prior comment.

What do I do to solve this problem?

2016-06-17 08:21:58 -0600 commented answer What is the current entropy generator?

So now I have another problem. I need an audio source. So what I did is I plugged in my MP3 player into the analog audio input of my server. The problem here is that the MP3 player will stop playing if it doesn't think it's hooked up to a receiver. After hooking up the MP3 player it stops playing after a few seconds because it doesn't recognize the server as being an authentic audio headset. I don't want to use a microphone to generate random audio because I'm in a small office where people are talking. The idea of having the server listening in on conversations is not make people feel comfort

2016-06-17 07:17:57 -0600 commented answer What is the current entropy generator?

This is my output.

* List of PLAYBACK Hardware Devices *

card 0: PCH [HDA Intel PCH], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]

Subdevices: 1/1

Subdevice #0: subdevice #0

card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]

Subdevices: 1/1

Subdevice #0: subdevice #0

My guess is I should change the line in the configuration file /etc/sysconfig/audio-entropyd

from....

--device=plughw:0

to....

--device=plughw:0,0

Is that correct?

2016-06-17 07:16:00 -0600 marked best answer What is the current entropy generator?

As per this#cite_note-3) link wiki page Fedora has a audio entropy package preinstalled. But the links are broken. What is the current entropy for Fedora 23? A search of this forum came up empty.

https://en.wikipedia.org/wiki/Entropy...