Ask Your Question

Revision history [back]

How can I get my Logitech G930 mute button to work?

I recently purchased a Logitech G930 USB headset. Most of its functionality works fine out of the box, including:

  • Stereo audio (no 7.1 surround)
  • The microphone for audio input
  • The 3 G keys which, out of the box, are configured to play/pause, rewind and fast-forward.
  • The volume roller

Unfortunately, there is a mic mute button that does not mute the microphone. Similarly, rotating the mic into a vertical position is also supposed to mute, but this doesn't work.

I've tested the headset under Windows 10 by mapping the USB device to the guest. The microphone mute button works without extra software under Windows (I.e. I have yet to install the G930-specific drivers.)

First I ran both showkey and showkey -s under a Linux console. This shows scancodes when I press all the buttons that work, but none when I press the microphone mute button. Likewise, I ran evtest on the keyboard device for the headset with similar results. Events were produced for every other keypress, but not for the mute button (didn't try the mic rotation in any of these tests.)

I assume that lack of a scancode/evtest event means that higher-level tests won't succeed either, but I tried them anyway. xev demonstrated the exact same behavior.

I've found various blog/forum posts on Google indicating that these buttons worked, but I'm wondering if they're just lumping the mute button in with the other media control buttons and claiming that it worked without individually testing it. One post in particular recommends tweaking the xorg configuration, but I don't know why I'd need to do this if a) the lower-level evtest isn't showing an event and b) other keys are being recognized.

Is there some easy-to-tweak reason that evtest may not see an event for this one button? Seems like a keypress is a keypress is a keypress, so it's odd that this one button is not only failing to generate a keypress, but isn't generating anything at all. Given that it works under Windows, I doubt it's a hardware failure.

Thanks.