Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

ATI GPU Fan is loud, can't turn it down using sys files...

Hi guys,

I recently installed an AMD Firepro V4900 Workstation card in my rig. I'm running Fedora 22, and I notice that the fan is really loud. I did quite a bit of googling (https://ask.fedoraproject.org/en/question/49667/fedora-20-ati-radeon-hd-4890-fan-is-running-on-100-all-the-time/) and (http://askubuntu.com/questions/324733/how-to-enable-the-radeon-dynamic-power-management-feature) and (https://wiki.archlinux.org/index.php/ATI#Profile-based_frequency_switching), and I've managed to enable Dynamic Power Management (DPM), but this didn't fix the problem. Running "sudo cat/sys/kernel/debug/dri/1/radeon_pm_info" gives:

uvd vclk: 0 dclk: 0 power level 2 sclk: 80000 mclk: 100000 vddc: 1100 vddci: 0

Notice that power level is 2 - this setting is appropriate for gaming/intensive CAD work, not casual use! I think the simplest fix would be "su -c 'echo low > /sys/class/drm/card1/device/power_profile' ", but when I try this, I get "bash: line 0: echo: write error: Invalid argument", even when root. I've also tried running chmod to make sure the file permissions are set to rw, but that didn't help. Any ideas?