Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to disable Nouveau, and install Nvidia.

I installed Fedora 21 a week ago. The first impression was verry good, and still is.

Some problems occured, and I had to make a reinstall. The last install, I also installed Nvidia drivers, with a little help from google. But then my wifi crashed, and I made a new install. Now I'm not able to install Nvidia, because of the nouveau driver. I can't remember what I did last time (I will make a guide next time :-) ), so I need some help.

This has been done (all in su)

yum install gcc kernel-devel

gedit /etc/modprobe.d/blacklist.conf echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

gedit /etc/sysconfig/grub added rd.driver.blacklist=nouveau in the GRUB_CMDLINE_LINUX=

grub2-mkconfig -o /boot/grub2/grub

grub2-mkconfig -o /boot/efi/EFI/fedora/grub (I don't know wich is used)

yum remoce xorg-x11-drv-nouveau.x86_64

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

dracut /boot/intirams-$(uname -r).img $(uname -r)

systemctl set-default multi-user.target

Well that's about it. What have I forgot, or what have I gone wrong?

I will reinstall and update fedora 21. A step by step instruction would have been nice :-)

How to disable Nouveau, and install Nvidia.

I installed Fedora 21 a week ago. The first impression was verry very good, and still is.

Some problems occured, occurred, and I had to make a reinstall. The last install, I also installed Nvidia drivers, with a little help from google. But then my wifi crashed, and I made a new install. Now I'm not able to install Nvidia, because of the nouveau driver. I can't remember what I did last time (I will make a guide next time :-) ), so I need some help.

This has been done (all in su)

su)

yum install gcc kernel-devel

kernel-devel gedit /etc/modprobe.d/blacklist.conf echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

/etc/modprobe.d/blacklist.conf gedit /etc/sysconfig/grub added rd.driver.blacklist=nouveau in the GRUB_CMDLINE_LINUX=

grub2-mkconfig -o /boot/grub2/grub

/boot/grub2/grub grub2-mkconfig -o /boot/efi/EFI/fedora/grub (I don't know wich which is used)

used) yum remoce xorg-x11-drv-nouveau.x86_64

xorg-x11-drv-nouveau.x86_64 mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

-r)-nouveau.img dracut /boot/intirams-$(uname -r).img $(uname -r)

-r) systemctl set-default multi-user.target

multi-user.target

Well that's about it. What have I forgot, or what have I gone wrong?

I will reinstall and update fedora 21. A step by step instruction would have been nice :-)

How to disable Nouveau, and install Nvidia.

I installed Fedora 21 a week ago. The first impression was very good, and still is.

Some problems occurred, and I had to make a reinstall. The last install, I also installed Nvidia drivers, with a little help from google. But then my wifi crashed, and I made a new install. Now I'm not able to install Nvidia, because of the nouveau driver. I can't remember what I did last time (I will make a guide next time :-) ), so I need some help.

This has been done (all in su)

yum install gcc kernel-devel

gedit /etc/modprobe.d/blacklist.conf
echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf

gedit /etc/sysconfig/grub
added rd.driver.blacklist=nouveau in the GRUB_CMDLINE_LINUX= 

grub2-mkconfig -o /boot/grub2/grub

grub2-mkconfig -o /boot/efi/EFI/fedora/grub    (I don't know which is used)

yum remoce xorg-x11-drv-nouveau.x86_64

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

dracut /boot/intirams-$(uname -r).img $(uname -r)

systemctl set-default multi-user.target

Well that's about it. What have I forgot, or what have I gone wrong?

I will reinstall and update fedora 21. A step by step instruction would have been nice :-)