Ask Your Question

Revision history [back]

Fedora 19 and NIS Issues on a Fresh Install

Hi everyone. I've just done a fresh Fedora 19 installation and I've encountered a usability issue. I have solved the problem, but I wondered if this is an issue with Fedora 19, and whether it's something that should be addressed by the devs?

My Fedora system is part of a larger home network. As every computer is installed with some flavour of Linux, I run NIS for the password and home directory information and autofs to mount the home dirs.

With some new components arriving in the middle of last week, I took the time to do a fresh install of my OS. After several struggles (Wednesday to Friday evenings and again until evening on Saturday) I finally overcame the GPT partitioning bugs and installed alongside Win7. During the install I didn't set up a user, as my users are already defined.

When I did the first boot up into Linux, however, I found to my annoyance that Fedora no longer gives you the opportunity to run authconfig, but now prompts you for your location, the date, then forces you to create a home directory... No option to use my standard accounts.

I could find no way round this. The box has no 'close' button, there is no 'advanced' or 'grown up user' button. I can do the ctrl-alt-f2 salute to get a text terminal and install autofs and YP (as they're not installed by default, and the package list no longer gives an option to select them), but I can't make this damn box go away on reboots. And I can't close it. It's utterly mental. The only way I could make my system give me a log-on was to run 'startx' after logging in as me on the command prompt screen (and then it gives me the horrid Gnome 3 user interface which drives me mad). It never gives the standard gdm login page. I never actually found out how to make it work properly, I just gave up (remember, three days and still no working system grates on the nerves somewhat).

My final solution was to install Fedora 18, which works properly by asking which user you want to create or allowing you to use authconfig interface to set up NIS, completely at your own choice. When this was done, I used fedup to upgrade to F19.

click to hide/show revision 2
No.2 Revision

Fedora 19 and NIS Issues on a Fresh Install

Hi everyone. I've just done a fresh Fedora 19 installation and I've encountered a usability issue. I have solved the problem, but I wondered if this is an issue with Fedora 19, and whether it's something that should be addressed by the devs?

My Fedora system is part of a larger home network. As every computer is installed with some flavour of Linux, I run NIS for the password and home directory information and autofs to mount the home dirs.

With some new components arriving in the middle of last week, I took the time to do a fresh install of my OS. After several struggles (Wednesday to Friday evenings and again until evening on Saturday) I finally overcame the GPT partitioning bugs and installed alongside Win7. During the install I didn't set up a user, as my users are already defined.

When I did the first boot up into Linux, however, I found to my annoyance that Fedora no longer gives you the opportunity to run authconfig, but now prompts you for your location, the date, then forces you to create a home directory... No option to use my standard accounts.

I could find no way round this. The box has no 'close' button, there is no 'advanced' or 'grown up user' button. I can do the ctrl-alt-f2 salute to get a text terminal and install autofs and YP (as they're not installed by default, and the package list no longer gives an option to select them), but I can't make this damn box go away on reboots. And I can't close it. It's utterly mental. The only way I could make my system give me a log-on was to run 'startx' after logging in as me on the command prompt screen (and then it gives me the horrid Gnome 3 user interface which drives me mad). It never gives the standard gdm login page. I never actually found out how to make it work properly, I just gave up (remember, three days and still no working system grates on the nerves somewhat).

My final solution was to install Fedora 18, which works properly by asking which user you want to create or allowing you to use authconfig interface to set up NIS, completely at your own choice. When this was done, I used fedup to upgrade to F19.

click to hide/show revision 3
No.3 Revision

Fedora 19 and NIS Issues on a Fresh Install

Hi everyone. I've just done a fresh Fedora 19 installation and I've encountered a usability issue. I have solved the problem, but I wondered if this is an issue with Fedora 19, and whether it's something that should be addressed by the devs?

My Fedora system is part of a larger home network. As every computer is installed with some flavour of Linux, I run NIS for the password and home directory information and autofs to mount the home dirs.

With some new components arriving in the middle of last week, I took the time to do a fresh install of my OS. After several struggles (Wednesday to Friday evenings and again until evening on Saturday) I finally overcame the GPT partitioning bugs and installed alongside Win7. During the install I didn't set up a user, as my users are already defined.

When I did the first boot up into Linux, however, I found to my annoyance that Fedora no longer gives you the opportunity to run authconfig, but now prompts you for your location, the date, then forces you to create a home directory... No option to use my standard accounts.

I could find no way round this. The box has no 'close' button, there is no 'advanced' or 'grown up user' button. I can do the ctrl-alt-f2 salute to get a text terminal and install autofs and YP (as they're not installed by default, and the package list no longer gives an option to select them), but I can't make this damn box go away on reboots. And I can't close it. It's utterly mental. The only way I could make my system give me a log-on was to run 'startx' after logging in as me on the command prompt screen (and then it gives me the horrid Gnome 3 user interface which drives me mad). It never gives the standard gdm login page. I never actually found out how to make it work properly, I just gave up (remember, three days and still no working system grates on the nerves somewhat).

My final solution was to install Fedora 18, which works properly by asking which user you want to create or allowing you to use authconfig interface to set up NIS, completely at your own choice. When this was done, I used fedup to upgrade to F19.

click to hide/show revision 4
No.4 Revision

Fedora 19 and NIS Issues on a Fresh Install

Hi everyone. I've just done a fresh Fedora 19 installation and I've encountered a usability issue. I have solved the problem, but I wondered if this is an issue with Fedora 19, and whether it's something that should be addressed by the devs?

My Fedora system is part of a larger home network. As every computer is installed with some flavour of Linux, I run NIS for the password and home directory information and autofs to mount the home dirs.

With some new components arriving in the middle of last week, I took the time to do a fresh install of my OS. After several struggles (Wednesday to Friday evenings and again until evening on Saturday) I finally overcame the GPT partitioning bugs and installed alongside Win7. During the install I didn't set up a user, as my users are already defined.

When I did the first boot up into Linux, however, I found to my annoyance that Fedora no longer gives you the opportunity to run authconfig, but now prompts you for your location, the date, then forces you to create a home directory... No option to use my standard accounts.

I could find no way round this. The box has no 'close' button, there is no 'advanced' or 'grown up user' button. I can do the ctrl-alt-f2 salute to get a text terminal and install autofs and YP (as they're not installed by default, and the package list no longer gives an option to select them), but I can't make this damn box go away on reboots. And I can't close it. It's utterly mental. The only way I could make my system give me a log-on was to run 'startx' after logging in as me on the command prompt screen (and then it gives me the horrid Gnome 3 user interface which drives me mad). It never gives the standard gdm login page. I never actually found out how to make it work properly, I just gave up (remember, three days and still no working system grates on the nerves somewhat).

My final solution was to install Fedora 18, which works properly by asking which user you want to create or allowing you to use authconfig interface to set up NIS, completely at your own choice. When this was done, I used fedup to upgrade to F19.