Ask Your Question

Revision history [back]

Transaction check error

Trying to update Fedora 29 I get the following error:

patrickm@thinkpadx230:/$ sudo dnf upgrade
[sudo] password for patrickm: 
Fedora 29 openh264 (From Cisco) - x86_64        389  B/s | 543  B     00:01    
Fedora Modular 29 - x86_64                       37 kB/s |  26 kB     00:00    
Fedora Modular 29 - x86_64 - Updates             23 kB/s |  22 kB     00:00    
Fedora Modular 29 - x86_64 - Updates            907 kB/s | 2.1 MB     00:02    
Fedora 29 - x86_64 - Updates                     29 kB/s |  20 kB     00:00    
Fedora 29 - x86_64 - Updates                    1.8 MB/s |  25 MB     00:13    
Fedora 29 - x86_64                               26 kB/s |  26 kB     00:00    
MEGAsync                                        4.9 kB/s | 1.5 kB     00:00    
RPM Fusion for Fedora 29 - Free - Updates        19 kB/s | 8.9 kB     00:00    
RPM Fusion for Fedora 29 - Free                  40 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 29 - Nonfree - Updates     43 kB/s | 9.1 kB     00:00    
RPM Fusion for Fedora 29 - Nonfree               22 kB/s |  10 kB     00:00    
Dependencies resolved.
================================================================================
 Package                     Arch   Version                     Repo       Size
================================================================================
Upgrading:
 SDL                         x86_64 1.2.15-37.fc29              updates   193 k
 autocorr-pt                 noarch 1:6.1.5.2-4.fc29            updates   170 k
 binutils                    x86_64 2.31.1-24.fc29              updates   6.0 M
 bleachbit                   noarch 2.2-1.fc29                  updates   533 k
 btrfs-progs                 x86_64 4.20.2-1.fc29               updates   726 k
 colord-libs                 i686   1.4.4-1.fc29                updates   220 k
 createrepo_c                x86_64 0.12.2-1.fc29               updates    64 k
 dracut-config-rescue        x86_64 049-26.git20181204.fc29     updates    12 k
 firefox                     x86_64 66.0.2-1.fc29               updates    89 M
 flatpak                     x86_64 1.2.4-1.fc29                updates   1.0 M
 freerdp-libs                x86_64 2:2.0.0-49.20190304git435872b.fc29
                                                                updates   870 k
 ghostscript-tools-fonts     x86_64 9.26-4.fc29                 updates    15 k
 ghostscript-tools-printing  x86_64 9.26-4.fc29                 updates    15 k
 gnome-characters            x86_64 3.30.0-2.fc29               updates   253 k
 gnutls                      i686   3.6.7-1.fc29                updates   892 k
 homebank                    x86_64 5.2.3-1.fc29                updates   889 k
 hyperv-daemons              x86_64 0-0.28.20190303git.fc29     updates   7.4 k
 hyperv-daemons-license      noarch 0-0.28.20190303git.fc29     updates    15 k
 hypervfcopyd                x86_64 0-0.28.20190303git.fc29     updates    13 k
 hypervkvpd                  x86_64 0-0.28.20190303git.fc29     updates    22 k
 hypervvssd                  x86_64 0-0.28.20190303git.fc29     updates    14 k
 java-1.8.0-openjdk          x86_64 1:1.8.0.201.b09-6.fc29      updates   239 k
 java-1.8.0-openjdk-headless x86_64 1:1.8.0.201.b09-6.fc29      updates    32 M
 kernel-headers              x86_64 5.0.5-200.fc29              updates   1.2 M
 kernel-tools                x86_64 5.0.5-200.fc29              updates   164 k
 kernel-tools-libs           x86_64 5.0.5-200.fc29              updates    19 k
 libargon2                   x86_64 20161029-7.fc29             updates    27 k
 libcap-ng                   i686   0.7.9-5.fc29                updates    27 k
 libcap-ng                   x86_64 0.7.9-5.fc29                updates    26 k
 libseccomp                  x86_64 2.4.0-0.fc29                updates    61 k
 libssh2                     x86_64 1.8.1-1.fc29                updates    85 k
 libxcrypt                   i686   4.4.4-2.fc29                updates   126 k
 libxcrypt-devel             x86_64 4.4.4-2.fc29                updates    34 k
 libzhuyin                   x86_64 2.3.0-1.fc29                updates   307 k
 mesa-libEGL                 i686   18.3.5-2.fc29               updates   115 k
 mesa-libEGL                 x86_64 18.3.5-2.fc29               updates   106 k
 mesa-libGL                  x86_64 18.3.5-2.fc29               updates   148 k
 mesa-libOpenCL              x86_64 18.3.5-2.fc29               updates   323 k
 mesa-libxatracker           x86_64 18.3.5-2.fc29               updates   1.2 M
 mod_http2                   x86_64 1.14.1-1.fc29               updates   144 k
 net-tools                   x86_64 2.0-0.53.20160912git.fc29   updates   277 k
 openldap                    i686   2.4.46-10.fc29              updates   299 k
 openssh                     x86_64 7.9p1-5.fc29                updates   419 k
 openssh-clients             x86_64 7.9p1-5.fc29                updates   539 k
 openssh-server              x86_64 7.9p1-5.fc29                updates   386 k
 openssl                     x86_64 1:1.1.1b-3.fc29             updates   631 k
 osinfo-db                   noarch 20190319-1.fc29             updates   187 k
 perl-Socket                 x86_64 4:2.029-1.fc29              updates    52 k
 polkit                      x86_64 0.115-4.4.fc29              updates   133 k
 powertop                    x86_64 2.10-2.fc29                 updates   230 k
 psmisc                      x86_64 23.1-4.1.fc29               updates   133 k
 python2-setuptools          noarch 40.8.0-1.fc29               updates   644 k
 qemu-guest-agent            x86_64 2:3.0.0-4.fc29              updates   119 k
 qpdf-libs                   x86_64 8.4.0-1.fc29                updates   469 k
 qt-x11                      x86_64 1:4.8.7-45.fc29             updates    12 M
 rsync                       x86_64 3.1.3-6.fc29                updates   380 k
 samba-client                x86_64 2:4.9.5-0.fc29              updates   538 k
 samba-libs                  x86_64 2:4.9.5-0.fc29              updates   101 k
 sos                         noarch 3.7-1.fc29                  updates   476 k
 sudo                        x86_64 1.8.27-1.fc29               updates   848 k
 texlive-lib                 x86_64 7:20180414-35.fc29          updates   496 k
 tpm2-tss                    x86_64 2.1.2-1.fc29                updates   254 k
 webkit2gtk3                 x86_64 2.22.7-1.fc29               updates    12 M
 whois-mkpasswd              x86_64 5.4.2-1.fc29                updates    38 k
 whois-nls                   noarch 5.4.2-1.fc29                updates    32 k
 zchunk-libs                 x86_64 1.1.0-1.fc29                updates    46 k
 ffmpeg                      x86_64 4.0.4-1.fc29                rpmfusion-free-updates
                                                                          1.3 M
 libtgvoip                   x86_64 2.4.4-1.fc29                rpmfusion-free-updates
                                                                          659 k
 telegram-desktop            x86_64 1.6.3-1.fc29                rpmfusion-free-updates
                                                                           16 M
Installing dependencies:
 kernel                      x86_64 5.0.5-200.fc29              updates    30 k
 kernel-core                 x86_64 5.0.5-200.fc29              updates    26 M
 kernel-modules              x86_64 5.0.5-200.fc29              updates    28 M
 kernel-modules-extra        x86_64 5.0.5-200.fc29              updates   2.1 M
Removing dependent packages:
 mesa-libGL                  i686   18.3.4-1.fc29               @updates  518 k

Transaction Summary
================================================================================
Install   4 Packages
Upgrade  69 Packages
Remove    1 Package

Total size: 243 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] kernel-5.0.5-200.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] kernel-core-5.0.5-200.fc29.x86_64.rpm: Already downloaded            
[SKIPPED] kernel-modules-5.0.5-200.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] kernel-modules-extra-5.0.5-200.fc29.x86_64.rpm: Already downloaded   
[SKIPPED] SDL-1.2.15-37.fc29.x86_64.rpm: Already downloaded                    
[SKIPPED] autocorr-pt-6.1.5.2-4.fc29.noarch.rpm: Already downloaded            
[SKIPPED] binutils-2.31.1-24.fc29.x86_64.rpm: Already downloaded               
[SKIPPED] bleachbit-2.2-1.fc29.noarch.rpm: Already downloaded                  
[SKIPPED] btrfs-progs-4.20.2-1.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] colord-libs-1.4.4-1.fc29.i686.rpm: Already downloaded                
[SKIPPED] createrepo_c-0.12.2-1.fc29.x86_64.rpm: Already downloaded            
[SKIPPED] dracut-config-rescue-049-26.git20181204.fc29.x86_64.rpm: Already downloaded
[SKIPPED] firefox-66.0.2-1.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] flatpak-1.2.4-1.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] freerdp-libs-2.0.0-49.20190304git435872b.fc29.x86_64.rpm: Already downloaded
[SKIPPED] ghostscript-tools-fonts-9.26-4.fc29.x86_64.rpm: Already downloaded   
[SKIPPED] ghostscript-tools-printing-9.26-4.fc29.x86_64.rpm: Already downloaded
[SKIPPED] gnome-characters-3.30.0-2.fc29.x86_64.rpm: Already downloaded        
[SKIPPED] gnutls-3.6.7-1.fc29.i686.rpm: Already downloaded                     
[SKIPPED] homebank-5.2.3-1.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] hyperv-daemons-0-0.28.20190303git.fc29.x86_64.rpm: Already downloaded
[SKIPPED] hyperv-daemons-license-0-0.28.20190303git.fc29.noarch.rpm: Already downloaded
[SKIPPED] hypervfcopyd-0-0.28.20190303git.fc29.x86_64.rpm: Already downloaded  
[SKIPPED] hypervkvpd-0-0.28.20190303git.fc29.x86_64.rpm: Already downloaded    
[SKIPPED] hypervvssd-0-0.28.20190303git.fc29.x86_64.rpm: Already downloaded    
[SKIPPED] java-1.8.0-openjdk-1.8.0.201.b09-6.fc29.x86_64.rpm: Already downloaded
[SKIPPED] java-1.8.0-openjdk-headless-1.8.0.201.b09-6.fc29.x86_64.rpm: Already downloaded
[SKIPPED] kernel-headers-5.0.5-200.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] kernel-tools-5.0.5-200.fc29.x86_64.rpm: Already downloaded           
[SKIPPED] kernel-tools-libs-5.0.5-200.fc29.x86_64.rpm: Already downloaded      
[SKIPPED] libargon2-20161029-7.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] libcap-ng-0.7.9-5.fc29.i686.rpm: Already downloaded                  
[SKIPPED] libcap-ng-0.7.9-5.fc29.x86_64.rpm: Already downloaded                
[SKIPPED] libseccomp-2.4.0-0.fc29.x86_64.rpm: Already downloaded               
[SKIPPED] libssh2-1.8.1-1.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] libxcrypt-4.4.4-2.fc29.i686.rpm: Already downloaded                  
[SKIPPED] libxcrypt-devel-4.4.4-2.fc29.x86_64.rpm: Already downloaded          
[SKIPPED] libzhuyin-2.3.0-1.fc29.x86_64.rpm: Already downloaded                
[SKIPPED] mesa-libEGL-18.3.5-2.fc29.i686.rpm: Already downloaded               
[SKIPPED] mesa-libEGL-18.3.5-2.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] mesa-libGL-18.3.5-2.fc29.x86_64.rpm: Already downloaded              
[SKIPPED] mesa-libOpenCL-18.3.5-2.fc29.x86_64.rpm: Already downloaded          
[SKIPPED] mesa-libxatracker-18.3.5-2.fc29.x86_64.rpm: Already downloaded       
[SKIPPED] mod_http2-1.14.1-1.fc29.x86_64.rpm: Already downloaded               
[SKIPPED] net-tools-2.0-0.53.20160912git.fc29.x86_64.rpm: Already downloaded   
[SKIPPED] openldap-2.4.46-10.fc29.i686.rpm: Already downloaded                 
[SKIPPED] openssh-7.9p1-5.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] openssh-clients-7.9p1-5.fc29.x86_64.rpm: Already downloaded          
[SKIPPED] openssh-server-7.9p1-5.fc29.x86_64.rpm: Already downloaded           
[SKIPPED] openssl-1.1.1b-3.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] osinfo-db-20190319-1.fc29.noarch.rpm: Already downloaded             
[SKIPPED] perl-Socket-2.029-1.fc29.x86_64.rpm: Already downloaded              
[SKIPPED] polkit-0.115-4.4.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] powertop-2.10-2.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] psmisc-23.1-4.1.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] python2-setuptools-40.8.0-1.fc29.noarch.rpm: Already downloaded      
[SKIPPED] qemu-guest-agent-3.0.0-4.fc29.x86_64.rpm: Already downloaded         
[SKIPPED] qpdf-libs-8.4.0-1.fc29.x86_64.rpm: Already downloaded                
[SKIPPED] qt-x11-4.8.7-45.fc29.x86_64.rpm: Already downloaded                  
[SKIPPED] rsync-3.1.3-6.fc29.x86_64.rpm: Already downloaded                    
[SKIPPED] samba-client-4.9.5-0.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] samba-libs-4.9.5-0.fc29.x86_64.rpm: Already downloaded               
[SKIPPED] sos-3.7-1.fc29.noarch.rpm: Already downloaded                        
[SKIPPED] sudo-1.8.27-1.fc29.x86_64.rpm: Already downloaded                    
[SKIPPED] texlive-lib-20180414-35.fc29.x86_64.rpm: Already downloaded          
[SKIPPED] tpm2-tss-2.1.2-1.fc29.x86_64.rpm: Already downloaded                 
[SKIPPED] webkit2gtk3-2.22.7-1.fc29.x86_64.rpm: Already downloaded             
[SKIPPED] whois-mkpasswd-5.4.2-1.fc29.x86_64.rpm: Already downloaded           
[SKIPPED] whois-nls-5.4.2-1.fc29.noarch.rpm: Already downloaded                
[SKIPPED] zchunk-libs-1.1.0-1.fc29.x86_64.rpm: Already downloaded              
[SKIPPED] ffmpeg-4.0.4-1.fc29.x86_64.rpm: Already downloaded                   
[SKIPPED] libtgvoip-2.4.4-1.fc29.x86_64.rpm: Already downloaded                
[SKIPPED] telegram-desktop-1.6.3-1.fc29.x86_64.rpm: Already downloaded         
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/samba/libMESSAGING-SEND-samba4.so from install of samba-libs-2:4.9.5-0.fc29.x86_64 conflicts with file from package samba-client-libs-2:4.9.4-1.fc29.x86_64
  file /usr/share/man/man5/ldap.conf.5.gz from install of openldap-2.4.46-10.fc29.i686 conflicts with file from package openldap-2.4.46-9.fc29.x86_64
  file /usr/share/doc/libxcrypt/NEWS from install of libxcrypt-4.4.4-2.fc29.i686 conflicts with file from package libxcrypt-4.4.3-10.fc29.x86_64
  file /usr/share/doc/libxcrypt/README from install of libxcrypt-4.4.4-2.fc29.i686 conflicts with file from package libxcrypt-4.4.3-10.fc29.x86_64
  file /usr/share/doc/gnutls/AUTHORS from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.6-1.fc29.x86_64
  file /usr/share/doc/gnutls/NEWS from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.6-1.fc29.x86_64
  file /usr/share/doc/gnutls/README.md from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.6-1.fc29.x86_64
  file /usr/share/licenses/gnutls/COPYING from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.6-1.fc29.x86_64

Error Summary
-------------

I have tried running it with --allow-erasing and --skip-broken but the same result comes out. I also tried package-cleanup --cleandupes, but it deleted half of the system.