Ask Your Question

Revision history [back]

python-sqlobject-1.2.2-3.el7.noarch shipped with EPEL 7 not compatible with PyGreSQL-5.0.6-1.rhel7.x86_64 from PostgreSQL 9.6

The python-sqlobject RPM requires "postgresql-python" meta RPM, which was provided by PyGreSQL:4.0-9 (from CentOS 7 repo) and PyGreSQL:5.0.3-1 (from PostgreSQL 9.6 Yum repo) as a migration path. Now PostgreSQL updated their repo with PyGreSQL:5.0.6-1, which does provide the newer "python2-PyGreSQL = 5.0.6-1", but not the "postgresql-python" meta RPM anymore. A dependency resolution fails.

Steps to Reproduce: 1. install PostgreSQL 9.6 repo: yum install https://download.postgresql.org/pub/repos/yum/9.6/redhat/rhel-7-x86_64/pgdg-centos96-9.6-3.noarch.rpm 2. yum install PyGreSQL 3. yum install python-sqlobject

Actual results: Loaded plugins: etckeeper, fastestmirror, priorities Loading mirror speeds from cached hostfile 17 packages excluded due to repository priority protections Resolving Dependencies --> Running transaction check ---> Package python-sqlobject.noarch 0:1.2.2-3.el7 will be installed --> Processing Dependency: postgresql-python for package: python-sqlobject-1.2.2-3.el7.noarch --> Finished Dependency Resolution Error: Package: python-sqlobject-1.2.2-3.el7.noarch (epel) Requires: postgresql-python Available: PyGreSQL-4.0-9.el7.x86_64 (base) postgresql-python = 8.5.0-1 Available: PyGreSQL-5.0.3-1.rhel7.x86_64 (pgdg96) postgresql-python = 8.5.0-1 Installed: PyGreSQL-5.0.6-1.rhel7.x86_64 (@pgdg96) Not found You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

Expected results: A successful installation.

Additional info: Newer upstream version of python2-sqlobject (note the "2") require "python2-PyGreSQL" directly (e.g. on Fedora). But this RPM is not contained in EPEL. Would it be a possible solution to include it?

I have created a bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1655070. What can I do to trigger processing?