Ask Your Question

Revision history [back]

Fedora 29 thinkpad T580 crashing/issues Please help :)

So I just recently bought a brand new thinkpad T580 and tried to put fedora 29 on it. At first the install went fine or so I thought and I was even able to use the laptop with fedora for like 3 hours the first night then I shut it off and went to bed. The next day I tried to use it again but this time It booted on, I logged in and the cursor moved super slow and nothing was working I couldn't even open settings. Then at the top I got a message saying "oops we're sorry, it looks like BOOT_IMAGE=/vmlinuz-4.20.8-200fc29 had crashed." Then it said there was an error and the error report opened up saying xorg-x11-drv-nouveau, system failure as well as system failure, system failure and vmlinuz-4.20.8-200.fc29.86_64 system failure. I restarted the computer and got it to install the updates so I thought maybe that would fix it but did not. I eventually tried to put opensuse on it and that seemed to work fine so I'm assuming it's not my laptop but I'm not 100 percent sure. I really want fedora on my laptop though so I tried to put fedora back on my laptop after using opensuse for a couple days and the same things happened. I'm not really sure how to troubleshoot the problem myself I've posted a thread on r/thinkpad and did some googleing but I have no idea what could be wrong. Any help would be greatly appreciated. If any of you have any ideas if it's fedora or my laptop please let me know. Thanks ahead of time for any help.