Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

File conflicts with file from package on fedora 28

My fedora 28 replace on 64-bit desktop.
After trying to update: dnf update.
I have an error: "Error: Transaction check error" and list of conflicts with message: "conflicts with file from package".
I had same problem on summer but I did nothing and conflicts disappeared. Now I have next:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/licenses/libcom_err/NOTICE from install of libcom_err-1.44.2-0.fc28.i686 conflicts with file from package libcom_err-1.43.8-2.fc28.x86_64
  file /etc/xattr.conf from install of libattr-2.4.48-3.fc28.i686 conflicts with file from package libattr-2.4.47-23.fc28.x86_64

Error Summary

How to fix it?
Upgrading the system to version 29 will help?